Jump to content
Corsair Community

H100i Pro XT potential hardware issue


Recommended Posts

Hi guys,

Signed up to the forum to ask this, as I'm pulling my hair out.

New build, installed the H100i RGB Pro XT AIO.  When using this device through the included USB cable to header, i'd start getting USB disconnects on all USB devices. 

After a bit of research, I found that i had to change the CPU FAN Header in my BIOS to PWM (instead of automatic).  This worked, and I got about 2 weeks of good use.  (On further research, I'm not even sure why this worked, as it appears that fix was meant for the H100i V2, not the Pro XT?????)

However, today I installed 6 new LL120 fans and a CoPro.  They all work perfectly fine.  However, now my CPU Pump is doing the USB disconnect again.  I've tried going into BIOS, but the CPU FAN Header is still set to PWM.  I'm now wondering if it might be something to do with a current draw from my USB headers?  I now have 1 header for the H100i, and 1 header for the CoPro (and 6 attached LL120 fans).  The only way to NOT get USB disconnects (that i can see) is to remove the USB from the pump head (which i've now done to save my sanity.  Obviously now though, i can't use custom lighting or fan curves).

Im not sure if it helps, but below are all the hardware i have - assuming it's DEFINITELY a hardware thing, not a software thing....

Ryzen 5600G CPU
MSI B550 Tomahawk Mobo
32GB Corsair Vengeance RAM (4x 8gb sticks)
H100i RGB Pro XT Cpu AIO with the stock non-RGB ML fans
ASUS TUG Nvidia GTX 1650 Super
NVME M.2 drive for boot
1x Sata HDD
Corsair RM850 Gold PSU
6x LL120 Fans, connected to RGB Fan Hub and CoPro.  **

The fans, hub and CoPro were all connected today (also, i previously had 16gb RAM connected, today i connected another 16gb - all the same brand, speed, SKU etc), and it's from today that the issue has started again.

Can anyone please help me with some advice on how to resolve?

 

Link to comment
Share on other sites

4 hours ago, ABGar27 said:

MSI B550 Tomahawk Mobo
32GB Corsair Vengeance RAM (4x 8gb sticks)
H100i RGB Pro XT Cpu AIO

This is a common result on any x570 or B550 motherboard. The communication is USB 2 related and there is no connection to tachometer wire on the XT. However, some devices are more vulnerable than others and the Platinum/XT coolers are frequently affected. Most owners of these boards need a powered USB hub to help offset the motherboard’s low output. These an relatively inexpensive (less than $20 USD) and often needed anyway to make up for limited usb 2 ports on the board. 

Link to comment
Share on other sites

Thank you, i'll order the NZXT hub and see how that goes.

I've seen a few threads where people have suggested disabling Global CStates, changing PCIE from 4.0 to 3.0, and updating Bios.

Do you think these are worth trying?  Or is it more likely just to use the hub to resolve (i haven't done any of the above before, and not sure how to do them TBH).

Thanks for the help and advice

Link to comment
Share on other sites

Also, a further issue (not sure if related or not due to power draw or config?) 

My CoPro today has duplicated itself somehow in iCue (appends the name with (1) at the end) , and keeps prompting to update firmware. I have done so, and confirmed the firmware version is the current one. However I update, and soon after it prompts me to do so again. (the update process doesn't appear to hang/stall, and appears to compete successfully). 

I saw a post advising to delete the iCue profiles which I have now done, and now only see the original CoPro. Could this have been caused by moving the usb ports when I tried to set up originally? I'll test tomorrow to see if it prompts firmware update again after deleting profiles.... 

Good thing the lights are so pretty... Not a great first experience

Link to comment
Share on other sites

Probably not.  The Commander(1), (1)(1), stuff is what happens when the firmware update fails and it decides your Commander is a different device.  I am not sure if you mean you deleted the profiles in CUE or you deleted the App Data folder that contains all of the settings and configurations.  However, my general advice for both of those issues is to do a clean install of the current version (4.19), which coincidentally has a fix for the multiple numbering.  However, that does require a clean install to avoid wrecking the device settings.  Hopefully you have some profile back ups.  The clean install will delete all settings, dashboard, and hardware lighting settings.

 

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

Link to comment
Share on other sites

Today i got the NZXT hub (the Sata version) and installed this.  Plugged it into my mobo.  Plugged both my H100i and my CoPro into the NZXT hub.

I did a full clean re-install of iCue version 4.19.191_release (following the instructions in above link, including regedit).  This seemed to fix the CoPro.

Then, when i loaded a game (Valorant), the H100i disconnected again.  This time, it tripped out the CoPro, which then on next restart had the same Firmware issue again.  I've forced the firmware update, and this time it's not showing duplicate CoPro's - so we'll wait and see on that.  Interestingly, when it disconnected, the Hardware Lighting for all my LL fans defaulted to a static Orange colour that i had used previously.  On the clean install, i set hardware lighting to default rainbow - so it's like it's picking up a historical profile file somewhere???

However, i still cannot use my H100i.  The only thing i can really do now is disconnect the USB from the H100i pump.  I know the pump still works, and so do the fans, so not damaging my PC, but I can't use custom curves or lighting on the pump now.

Any other suggestions on how I can resolve this issue?

Edited by ABGar27
Link to comment
Share on other sites

So when you were gaming, the XT and the Commander Pro dropped out and locked up even when on the powered hub?  Did you connect the XT directly to the hub or is it piggybacking on the C-Pro still?  
 

I would start a support ticket with Corsair. The dropping stuff happens, but requiring a forced firmware update is not normally part of that chain of events. This seems like an individual device problem (XT), but I am concerned the Commander locked up too. 

Link to comment
Share on other sites

I have both the CoPro and the H100i both plugged directly into the NZXT hub, which is then of course connected to my mobo directly.  There is nothing piggybacking into my CoPro.

And yep, it seems that when the system comes under a bit of load (i.e. i load a game), the H100i "disconnects", and locks up.  I have now removed the USB plug from the H100i to avoid the constant disconnect/reconnect of USB sounds that it would cause (it was also causing other devices on the same USB circuit (not sure if that's the right word) to disconnect. 

The CoPro's issue is super weird to me.  I hear a disconnect USB sound, and then iCUE pops up a notification saying that the CoPro needs updating to version 0.9.212.  This is the same firmware version that is already installed (i have double and triple checked this).  But, until i do the firmware update, the CoPro hangs, and won't let me do anything. The fans default to a standard fan curve.  HOWEVER (and this is the bit that's really throwing me), the fans then default to an orange hardware colour on the LEDs.  This is something i haven't had for several days now. I definitely (double and triple checked) set the hardware lighting setting to Rainbow Wave, but when the CoPro glitches out, it's like it's forgotten all of the settings, and defaulted to something that I used to have. If i restart Windows before the CoPro glitches, it remembers the correct settings (i.e. rainbow wave hardware lighting), but then when it glitches again, it reverts back to orange. ALSO, when the notification about a firmware update pops, another message prompts saying something like, "We noticed a sensor in port 1, are you trying to setup a Hydro cooler".  I definitely do NOT have any sensors plugged into the CoPro at all.  And never have.

I've now attempted a hard reset of my CoPro (pressing the button with a paper clip, while doing so, disconnecting Sata and then reconnecting 10 seconds later).  I have also done a full clean reinstall of ICUE.  Currently the CoPro is working as expected (as i reset it 20 minutes ago), but i feel it will glitch again when i put the PC under load - i will test and confirm tomorrow.

I'll definitely raise a support ticket, but just want to confirm if you have any other ideas based on the above additional information?

By the way, will changing PCIE from 4 to 3 help?  Or disabling global C-States?  I have read on other forums that they have helped with other specific situations, but i cannot tell why that would be.....

Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...