Jump to content
Corsair Community

WTH Replacement Voyager GTX 128gb Windows 11 won't work!


Recommended Posts

HI,

Right I got a replacement 128GB Voyager GTX for my dead 128GB GT Model that worked fine every single time in WIndows 11 with each insertion and it died no light whatsoever.

 

Anyway fast forward to today I get a GTX replacement and it will not work properly in Windows 11 ( I don't have another OS to test it)

First time it worked and now it just keeps freezing my computer randomly trying to access it, Sometimes it works first time in certain USB ports sometimes it doesn't, Sometimes the driver pops up in my computer but does not initialise properly and freezes my system again.

My system is as follow, Brand new Alder Lake upgrade a couple of months ago, 12900K all logitech wireless stuff, Asus ROG Strix Z690 Mobo, All my other USB sticks and devices work fine so there is nothing wrong with the system itself there seems to be an issue with these GTX drives, I don't know if it's a driver thing or what but it should not be doing what it is doing when I have 3 other perfectly fine USB sticks that initialise straight away upon insertion.

 

I should add for some reason this GTX stick is being detected as an SCSI device in device manager, I have no idea why and maybe that's the issue but if this device is indeed an SCSI device then no wonder it is not working properly and why are these sticks still being sold if there is no driver available for Windows 11?

Not sure what to do from here this is a warranty replacement and it's just random whether it initialises or not.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...