Jump to content
Corsair Community

XD7 Distro Problems


Recommended Posts

Okay so having built my loop with the XD7 in place I simply can not get the coolant to move freely around the system. There was no available cooling block for my GPU, 3060Ti, so I set up the distro to cool my CPU only. I followed the instructions to the letter and have watched a number of installation videos on the subject. However no matter how hard I try it seems I can not get the coolant to move through the tubes, what little movement that does occur through the pump seems to take an age. I even bled the system and tried again from scratch. After filling the reservoir almost to the top, there is still again no movement. The only way to get the coolant to move at all is to physically move the case from side to side. Yes there are air bubbles present and after a full 24hr leak test and what seemed like hours of moving the case in various directions to relieve any air blocks, there was still no progression whatsoever. The coolant just sits there in the tubes and basically does nothing. I cant even get it to travel as far as my cpu cooling block. The pump makes all the right noises and certainly gives the impression it is working properly but the end result is always the same. Molex connection is correct and is the only connection apart from the bridged 24 pin. If there's something I'm missing here I would appreciate any help. Cheers

Link to comment
Share on other sites

If it works like all others, the distro plate needs to have a GPU fitted. water goes from block to block, out of the distro, back in.. and on to the next component.

So if you have no GPU, you need to put a piece of tube between the GPU send and GPU return of the distro plate to complete the circuit.

Look at the quick start guide on page 4 https://www.corsair.com/corsairmedia/sys_master/productcontent/49_002309_revAC_WW_HXS_XD7_RGB_QSG.pdf

Link to comment
Share on other sites

2 hours ago, LeDoyen said:

If it works like all others, the distro plate needs to have a GPU fitted. water goes from block to block, out of the distro, back in.. and on to the next component.

So if you have no GPU, you need to put a piece of tube between the GPU send and GPU return of the distro plate to complete the circuit.

Look at the quick start guide on page 4 https://www.corsair.com/corsairmedia/sys_master/productcontent/49_002309_revAC_WW_HXS_XD7_RGB_QSG.pdf

The one thing I completely overlooked which of course makes perfect sense. Thank you for pointing this one out, much appreciated 👍

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...