Jump to content
Corsair Community

PWM Repeater not recognized in Commander XT


Recommended Posts

Hi everyone,

I just got done building a new PC using an iCue 7000X RGB tower. Everything went smoothly but I have some trouble with the PWM repeater and Commander Core XT.

The setup is as follows: Port 1-3 are three fans on top. Port 4 is connected to the repeater. The repeater connects the three front facing fans (seen left marked 1,2 and 3) - note that the "FAN 1" pin is connected (with input labeled 3 on the top left). Port 5 on the Commander is the single pre-installed fan on the back. Port 6 is the water pump.

iCue shows 5 devices connected, it's missing the PWM repeater. Thus, the front facing fans are off. Whichever Port i plug the PWM repeater in is not visible after a full power cycle. BUT: If I connect the PWM repeater to another port visible in iCue while the PC is running, the fans will turn on and I'll be able to control them and have an RPM reading. So I guess the Commander can't correctly identify the repeater on bootup, everything else seems to be in order (power and cables). Does anybody have an idea what I'm doing wrong?

Thanks everyone in advance!

 

image.thumb.png.7e0b81e748aae30307ef2d6aa76bcd42.pngimage.png.d655389c4d57cb631450b677ecdb2809.png

(This is the working configuration where I unplugged the back fan and instead connected the repeater there, labeled "Front". There's still only 5 devices shown though. In this config the back fan is off, even though it's plugged in.)

Link to comment
Share on other sites

The Commander Core and XT controllers use an auto-detect protocol for PWM and RGB. The PWM detection can be frustrating as it turns off the port when it fails to detect on boot. That makes fan swapping and troubleshooting annoying. You usually need to do a full power down to force the controller to power cycle. 
 

However, it’s clearly missing on power on now unless you been putting into S3 sleep or hibernate. Try swapping the “control” fan on the PWM hub with one of the others (3<->2 or 1). I see that issue across various brands of fan and hub, although the normal result is fans at max. You may be getting a different result because of the auto-detect and shutoff. 

Link to comment
Share on other sites

i kind of had this in my 7000d, i missed putting a fan in port one in the repeater but i can see you did this.

I found that from the commander pro i had to set the fan from auto to 4pin pwm in configuration of the port.... might be worth a try?

Link to comment
Share on other sites

Yes, if you are using all PWM fans on a Commander Pro, definitely change the header setting to 4 pin.  This skips the fan test on power on and it starts with 12v PWM and quiet fans.  Necessary for things like pumps as well.  Unfortunately, DC fan support was dropped from the Commander Core/XT series so those ports are all PWM only and that setting is gone.  The auto-detect and shut-off can create some difficulties if things don't go right.  

Edited by c-attack
Link to comment
Share on other sites

Sorry for the late reply and thank you both kindly for your answers. As suggested, I switched two fans in the repeater (3 and 2) and now have much more consistent results. In almost all cases, all fans are detected properly now. Every now and then (after booting from UEFI settings for example) it happens that only 2(? instead of 6!) fans are shown, which is super weird. But a power cycle fixes that. So for the moment I'm satisfied 🙂 Thank you!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...