Jump to content
Corsair Community

H150i pump speed stuck on extreme despite set to quiet in iCUE


Recommended Posts

Hi all, I have an H150i Elite Capellix and today I noticed PC was louder than usual. Turns out it is the AIO pump. I checked iCUE and despite it being set to quiet(which was default for me) it is running at full speed, ~2700. I've toggled all the different presets but nothing changed. When I built my PC a few weeks ago I started with version 3, it wasn't showing all of my sensors so I installed 4 and got the sensors.  Everything was fine and I kept the pump speed on quiet(~2200 - ~2400 I believe) as it made a difference in noise but no difference in temperatures.  I have no idea why it is suddenly stuck at max.  Tried restarting service, restarting pc, going back to version 3, and forcing an update on the pump, nothing is working and the whine is quite annoying, especially at night. Any ideas?"

Link to comment
Share on other sites

I got it figured out but will leave this up in case anyone else has a problem.  I decided I was going to do a full power down including disconnecting PSU, and reseat everything.  It worked, and when I reseated the connection from AIO to the controller there was a slight angle to the connection so it is quite possible it's been barely making the connection from the beginning and then finally came loose.  My assumption is if there is no connection to the controller the pump just runs full speed.  

Link to comment
Share on other sites

  • 2 weeks later...

just wanted to thank you man! i was just getting ready to rma....ive been battling this for like a week...figured id give it one more shot....found this post....boom...this fixed my issue... youre the man!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...