Jump to content
Corsair Community

H100i Platinum fans keep ramping up and down


Recommended Posts

Hey,

My H100i Platinum fans keep ramping up and down significantly when playing games/under load. I've actually managed to resolve this problem before by setting the CPU_FAN's Speed control to "Full Speed" and Control Mode to: "PWM" but after a recent Windows update, the problem reoccurred somehow lol.

I have a Ryzen 9 5950X on a B550 Aorus Master (F14D BIOS). If necessary I can provide screenshots from my Smart Fan 5 configuration but right now its basically just:

CPU_FAN:
CPU Fan Speed Control: Full Speed
Fan Control Use Temperature Input: CPU (Can't change this obviously)
Temperature Interval: 1
CPU Fan Control Mode: Auto
CPU Fan Disabled: Disabled

Setting my Fan Control mode to PWM or Voltage also didn't resolve this problem.
I also tried setting a Fixed RPM of 1250 in iCUE to the fans but that also didn't resolve this issue.

I am not that knowledgeable when it comes to fan configurations so I appreciate any help/suggestions to resolve this.

Link to comment
Share on other sites

The BIOS setting do not affect the Platinum’s operation unless you are controlling the fans from the MB for some reason. The connection to the motherboard is to satisfy the BIOS safety check for a cooling solution. This is why it goes to cpu fan, although the safety feature can be turned off. 
 

If you’ve connected the fans to pump’s fan controller as intended, then control is through CUE. If they do not respond to input control there, you may need to force update the firmware to reset the controller. However, it would be better to make sure the fans are connected to the Platinum, you are not using other monitoring software that can interfere (hwinfo, AIDA, etc), and that the fan curve is properly applied before force updating. 

  • Thanks 1
Link to comment
Share on other sites

Thanks for responding! I uninstalled all other monitoring software I had (Core Temp and some Gigabyte Monitoring Utility) then restarted my PC but it's still the same issue. The fans are connected to the Platinum since the fans aren't showing up in my Commander Pro but in my H100 Platinum:

 

 

Game.PNG

Link to comment
Share on other sites

That fan speed is about right for 37C on the coolant and the Quiet profile. There’s no way to know that unless you know the curve, which is hidden. This is why I recommend most people make a copy of the preset in the custom curve area. 
 

1) + to create a new curve.
 

2) Go to the lower right corner and select the second shape tool from the left. That is the quiet preset (balanced and extreme are I the next two to the right). 

 

3) Change the sensor to H100i platinum temp (coolant temperature). 
 

Now you can see and move the dots. This gives you two options to test. Drop the fan speed at 37C to 600 rpm and see if the fans move. The other is to use the fixed RPM/% option to force a fan response. 
 

Core temp should not be causing issues. Unsure on the Gigabyte utility. 

  • Thanks 1
Link to comment
Share on other sites

Posted (edited)

Thanks for your response. Right, I did what you mentioned, made a custom fan curve, changed the sensor, moved the dots. My fans definitely slow down but my fans still keep ramping up after booting up a game. I even tried to put it to 300 rpm and after a minute of 3 after booting up a game it ramps up again to like 4500 rpm.

Edited by Daravae
Link to comment
Share on other sites

If you are starting off at 37C, you likely cross the 40C=100% line pretty fast. There is nothing special about 40C, but they have to pick something. Either adjust your curve upwards so the high speeds are around 50C instead or you can set a fixed speed prior to gaming. 

  • Thanks 1
Link to comment
Share on other sites

Posted (edited)

I tried that as well and it didn't fix it. It feels like doing anything to the curve doesn't resolve anything as soon as I go play games. What happens is that the fans ramp up severely for a second or 2 and then it ramps down again and stays like that for 30s or so, but in idle the fan speeds move along just fine with whatever curve I set it to. The odd thing is I resolved this before by just setting the fan speed to Full Speed and PWM in the BIOS and after a Windows update, all of the sudden the problem returned. I don't want to roll back because of security updates as well. Kind of a frustrating problem ngl.

Edit: Setting a fixed speed for gaming also doesn't fix anything.

Edited by Daravae
Link to comment
Share on other sites

23 minutes ago, Daravae said:

fans ramp up severely for a second or 2 and then it ramps down again and stays like that for 30s or so

This can happen if the sensor (control variable) is set to CPU temp by mistake.  If it's not, then I think it's time to force a firmware update on the Platinum.  Check for updates.  It will come back as "none".  Then the force update option will become available.  While it's reloading the firmware, the fans will max out briefly.  The Platinum fan controller does have a tendency to get stuck, but normally its at maximum and the inconsistency suggests there may be a different problem.  

 

If that does not resolve things, it's time to contact Corsair Support.  The inability to maintain a fixed speed is worrisome.  It's possible the fan controller is failing.  

Link to comment
Share on other sites

I tried the firmware update as well. Unfortunately it's the same issue. Thank you for all of your help and suggestions. I raised a support ticket with Corsair. I'll follow up on what comes out of that.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...