Jump to content
Corsair Community

MM800 Not Recognized on MacBook Pro M1 Max


Recommended Posts

I've had a full Corsair set of K57 Wireless, Nightsword RGB, and the MM800. They all worked perfect on all of my Intel based Mac products under iCue 3.x versions. I recently upgraded to a MacBook Pro M1 Max, copied over the exact settings, and everything but the MM800 is recognized now. The computer doesn't even know its plugged in. Its the rainbow swirl design and a Stream Deck plugged into its USB port is working.

I upgraded to iCue 4 (the latest version) and its still not a device recognized in the software. Have tried multiple USB ports, etc. Sometimes the rainbow swirl doesn't even come on, but when its working as is, Corsair's iCue doesn't see it. Any thoughts on the Apple Silicon possibly being the issue?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...