Jump to content
Corsair Community

Error Lt100 Kit Started


Recommended Posts

Since the last version of icue (4.8) I had an error with my Lt100, it's not detected....

I have done a clean unstillation, test in another computer and I have the same error... when I connect the Lt100 in windows display the error "usb device error.."

I have installed a previous version and the same error...

Any help please???

Thanks

Link to comment
Share on other sites

I'm on same iCUE version and I do have LT100 as well, no problems here.

 

Have you tried changing USB port? Some Corsair products is very strict of what USB they are in, there has to be enough power, no cuts out, no nothing.. I've had the problem so many times now, I do own lots of Corsair stuff tho. Only thing that works is keep trying different ports and if that doesn't do the job, then buy a powered USB hub, since I did that, I haven't had the problems since.

 

Might not be related to your problem, but it's worth a try.

Link to comment
Share on other sites

I suspect that @Conver is correct here. How much do you have, total, on USB? How much RGB in your system? All of these use the 5V rail which isn't as strong as your 12V rail.

I had issues with my K100 dropping out once upon a time ... I moved a BUNCH of external USB devices to high-quality powered USB hubs and haven't had any issues at all since then.

  • Like 1
Link to comment
Share on other sites

Hi both,

 

Thanks for your help! I have found the problem... was the usb cable I have tested with another cable and is working... I don't know why becase the cable seems fine...

Thanks again

Edited by Cavernas
word wrong
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...