Jump to content
Corsair Community

QL120 Fan lighting not working.


DeeGeeNZ
 Share

Recommended Posts

Today i installed new 6 QL120 fans in my pc (2 x 3 packs) as per corsair reccomendations and i cannot get the lighting to work properly. All that is happening is the first fan is lighting up white with a flickering yellow led in the corner, changing the settings in icue does nothing the lighting seems completely unresponsive.

I have tried

  • Uninstalled amory crate/aura sync
  • Reinstalling icue (Multiple times including using the old version)
  • Switching around fans on controler (Each fan will show the same lighting effect when plugged into port 1 on the LNC)
  • Using the other LNC that came with the second set (Exact same result only first fan only white with one flickering yellow)
  • Changing the usb port that the LNC is plugged into

Have tried every single trouble shooting method i have found online but absolutely no luck. Hoping its something simple im missing but at this point ive exhausted all other avenues i could find.

The fans are working fine as fans at least so thats a start would just be nice to get the RGB working as well.

Have included a picture of icue config and what the one fan thats lighting up looks like.

20211230_203200.jpg

20211230_203216.jpg

unknown.png

Link to comment
Share on other sites

4 hours ago, DeeGeeNZ said:

Switching around fans on controler (Each fan will show the same lighting effect when plugged into port 1 on the LNC)


This is almost always a bad LED on the lead fan and the series circuit comes to a dead end. It looks like there might be one LED on for #2.  Can you swap RGB 2<->6 so the second fan is now last in the series?  If 2 is the problem and you kept rotating a new fan into 1 with a bad fan in 2, the effect would be consistent across your testing. 

Link to comment
Share on other sites

6 hours ago, c-attack said:


This is almost always a bad LED on the lead fan and the series circuit comes to a dead end. It looks like there might be one LED on for #2.  Can you swap RGB 2<->6 so the second fan is now last in the series?  If 2 is the problem and you kept rotating a new fan into 1 with a bad fan in 2, the effect would be consistent across your testing. 

Tried this and no difference i now have fan 2 in 6th port on LNC fan 1 in port 5, fan 5 in port 1, fan 6 in port 2 and still same issue but instead of fan 1 being on fan 5 is on with the exact same thing, all white with flickering yellow on one led.

20211231_075337.jpg

20211231_075344.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...