Jump to content
Corsair Community

Setup unable to install due to some error


Recommended Posts

I just got a new corsair keyboard, but when i try to install the ICUE 4 and ICUE 3 software i get this error message
"Setup unable to install due to some error"

I have not had the icue software installed previously.
 

i have tried:
  Installing previous versions of the software, installing both on my external harddrive F:/ and my C:/ drive

This is my msi.log

MSI (s) (B0:A8) [22:42:14:732]: Running installation inside multi-package transaction C:\Users\gilbe\Downloads\iCUESetup_4.18.209_release.msi
MSI (s) (B0:A8) [22:42:14:733]: Grabbed execution mutex.
MSI (s) (B0:BC) [22:42:14:738]: MainEngineThread is returning 1603
=== Verbose logging started: 24-12-2021  22:42:14  Build type: SHIP UNICODE 5.00.10011.00  Calling process: C:\Users\gilbe\AppData\Local\Temp\MSI16204\qt-dependencies\InstallerGui.exe ===
MSI (c) (2C:38) [22:42:14:722]: Resetting cached policy values
MSI (c) (2C:38) [22:42:14:723]: Machine policy value 'Debug' is 0
MSI (c) (2C:38) [22:42:14:723]: ******* RunEngine:
           ******* Product: C:\Users\gilbe\Downloads\iCUESetup_4.18.209_release.msi
           ******* Action: 
           ******* CommandLine: **********
MSI (c) (2C:38) [22:42:14:723]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (2C:38) [22:42:14:723]: Grabbed execution mutex.
MSI (c) (2C:38) [22:42:14:726]: Cloaking enabled.
MSI (c) (2C:38) [22:42:14:726]: Attempting to enable all disabled privileges before calling Install on Server
MSI (c) (2C:38) [22:42:14:726]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (c) (2C:38) [22:42:14:743]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (2C:38) [22:42:14:744]: MainEngineThread is returning 1603
=== Verbose logging stopped: 24-12-2021  22:42:14 ===

Link to comment
Share on other sites

  • 1 month later...

SOLVED:  So I finally figured out how to get around this after uninstalling/deleting everything I could find related to Corsair and even all RGB programs installed on my PC.

Follow the instructions on this page to install the MSI package as an admin

I did the command prompt option and it worked like a charm to install normally.  Unfortunately, for me, I had deleted my profile by that point so I had to set up all my options again, but it wasn't too bad.  I now can use my macro keys again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...