Jump to content
Corsair Community

Icue H100i Elite Capellix's Commander core update


Aero C
 Share

Recommended Posts

Hello;

 

I bought the Icue H100i Elite Capellix and it worked fine for few days.

But suddenly, i lost control of it in the Icue app.

It shows unknown device, even that it knows that it's a cooler, and it keeps working.

When i force an update, it shows up for a second then disappears.

I tried every possible solutions:

  1. Reinstalled driver
  2. Reinstalled ICUE
  3. Force firmware update
  4. Change USB port in the MB
  5. Reconnect all cables
  6. reinstalled the whole OS
  7. Deleted device
  8. Changed  SATA cable and connected directly to the PSU

 I had to contact Amazon and asked for an exchange, when i installed it, it worked fine, till the Icue forced me to update and then i lost control of the commander again. That's when i knew it was the Firmware problem.

I searched for hours looking for a previous firmware, but no luck.

The problem comes from the v 2.6.201

Can you send me a previous firmware to fix my problem.

Thank you in advance.

PS: Sorry for my bad English, it's my 4th language.

Edited by Aero C
  • Like 1
Link to comment
Share on other sites

It weird to force an update if it's not stable, and don't do anything about it if it's widespread.

At least put old firmware somewhere so we can downgrade.

I'm not even at my best settings, and i'm stuck with latest done.

I even had to order a replacement for the H100i, for nothing, a simple update is even harmless to the planet. 

Link to comment
Share on other sites

  • 3 weeks later...

Did anyone figure this out? I'm just now running into the same issue.

Link to comment
Share on other sites

I am also Experiencing this issue. I've rewired the whole fan configuration, checked connections, switched USB headers, reinstalled icue, everything is up to date, this issue happened as soon as I updated to the new firmware version.

My h100i is no longer appearing in device manager either, while it is cooling and seems to be working fine. The lights also come on while the computer is booting, but turn off as soon as icue is opened. I have a commander core XT that is working fine.

Edited by Cecor
  • Like 1
Link to comment
Share on other sites

Yep, we all have the same problem, and surely it comes from the latest Commander core update.

I've been in contact with customer service since December 19th 2021. in English and in French, and no solution till now.

I tried more and more solutions with no luck.

And i have 2 H100i thanks to Amazon, So it's not a hardware problem.

Check the firmware version, is it the v 2.6.201 ?

Edited by Aero C
Link to comment
Share on other sites

  • 4 weeks later...

Hello, I tried almost 20 solutions, None worked.

I didn't get the downgrade. Even that i asked for it, Maybe it's not the real problem.

So i got a replacement from Amazon and tried a different combination of H100i and the commander Core, and i gained back access.

But almost broke my CPU, because the cooler was stuck to it.

I'm followed by the English customer service for more than 2 months.

Good luck.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...