Jump to content
Corsair Community

My M65 Sniper Button gets "stuck" after recent iCue update!


Beefy1223
 Share

Recommended Posts

Greetings community members and expert staff! For some reason, after updating iCue to the newest version that I downloaded yesterday, 4.18.209, the sniper button on my M65 RGB mouse "sticks" in an activated mode even though I released it. It REALLY screws up my shots and is very annoying to deal with. This is, in my opinion, the best FPS and shooter game mouse on the market, with excellent weight, friction, customization and response.

Please help! If anything, how do I revert to a former version of the software? The worst thing is that it was working just fine til I updated. I have completely uninstalled and reinstalled and restarted as well as washing out all my mouse drivers and reinstalling them. I have removed my profile and completely remade it. I only use two DPI settings, the base one at 1750 and sniper button at 350, if that makes a difference.

Thank you!

  • Like 1
Link to comment
Share on other sites

Assuming this isn’t a mechanical problem, try running a quick repair install of cue from the Windows Settings/Apps list. Click on Corsair iCUE and select modify. This will not erase profiles or settings and often cleans up weird key/binding issues on mice and KBs. If that does not work, we’ll need to look at more invasive measures. 

Link to comment
Share on other sites

Same Issue with my nightsword rgb mouse since Icue 4.18.209. First thought it´s maybe a mechanical defect, but now i figured out it`s reducable:
When the sniper button is hold for at least 5sec, dpi switch sticks activated. Have to press the button it again for release.  

  • Like 2
Link to comment
Share on other sites

_xe_ this is PRECISELY what I am experiencing. At least I now know that it's software. Let's hope Corsair figures it out sooner than later.

Quote

When the sniper button is hold for at least 5sec, dpi switch sticks activated. Have to press the button it again for release.

 

Link to comment
Share on other sites

3 hours ago, _xe_ said:

When the sniper button is hold for at least 5sec, dpi switch sticks activated

I can reproduce that as well.  However, I suspect it might be intended.  I have not noticed it before because I remap the M65 and Nightsword sniper buttons to another task.  

Link to comment
Share on other sites

3 hours ago, c-attack said:

I can reproduce that as well.  However, I suspect it might be intended.  I have not noticed it before because I remap the M65 and Nightsword sniper buttons to another task.  

Intended? Why on Earth would that be a thing? And if so, why not make it a toggle option instead of ********ing everyone at the same time?

Link to comment
Share on other sites

Interesting to say the least. The latest update (on 12/17/2021) for Corsair has also affected (my) Dark Core RGB's sniper button functions too; with that said I think I can assume it was the latest update that has caused and added a 5 second hold down to toggle-on the sniper button's DPI function. It's fairly inconvenient for gaming so I had made a post the other day asking if there was a way to disable the 5 second hold-to-toggle function, and if not, is there a way to revert the update. I also mentioned that the toggling of the sniper button does seem to randomly turn on at times. So I suppose we can only wait until a response or fix comes up for the update. In the mean time I'll try not to use it so much.

  • Like 1
Link to comment
Share on other sites

I enjoy the fact and find it humorous that Corsair did not need to screw with anyone's mouse but that the update does it anyway. How do you do that, even accidentally? I also find it funny that the selling point, the reason to actually own, all of our mice has been completely ablated.

Haha.

Link to comment
Share on other sites

It seems awfully precise to be a bug and I think it is meant to be a key lock to save you from having to hold it down for 10-15 seconds plus.  No idea how long it has been like that since I don't use the sniper as a hold key.  So you guys think this is new in 4.18?  I don't see anything in the release notes or going back about 5 versions.  

  • Confused 1
Link to comment
Share on other sites

1 hour ago, c-attack said:

 So you guys think this is new in 4.18?  I don't see anything in the release notes or going back about 5 versions.  

Yes, behaviour is new since v4.18. Using my mouse for over 2 years and serveral icue versions.
It doesn`t make sense for gaming. For "permanent" dpi change you can switch between 3 dpi profiles. There are 2 buttons mentioned for this per default 😉   

  • Like 1
Link to comment
Share on other sites

  • Corsair Employees

What exact M65 mouse are you experiencing this issue with?

Link to comment
Share on other sites

I have replicated it on the M65 Elite and Nightsword.  As mentioned above, it requires an approximate 5 second hold before it locks to the sniper set DPI.  An additional DPI click releases it.  

Link to comment
Share on other sites

6 hours ago, c-attack said:

It seems awfully precise to be a bug and I think it is meant to be a key lock to save you from having to hold it down for 10-15 seconds plus.  No idea how long it has been like that since I don't use the sniper as a hold key.  So you guys think this is new in 4.18?  I don't see anything in the release notes or going back about 5 versions.  

This is awful. I'm okay with holding onto the button for minutes at a time so I'm not sure why this was implemented. It's very annoying when I have a target acquired and I go to snap someone coming around another corner and I am sluggish to the shot and I get taken out. It happens A LOT. If this is a permanent change, the M65 may no longer be for me, which would be a shame since I own 3 backups in case something mechanical goes wrong.

 

 

3 hours ago, Corsair Notepad said:

What exact M65 mouse are you experiencing this issue with?

Attached. Corsair M65 RGB Elite.

Screenshot_2.jpg

Link to comment
Share on other sites

4 hours ago, _xe_ said:

Yes, behaviour is new since v4.18. Using my mouse for over 2 years and serveral icue versions.
It doesn`t make sense for gaming. For "permanent" dpi change you can switch between 3 dpi profiles. There are 2 buttons mentioned for this per default 😉   

Completely agree, hell, my mouse has 5 profiles if people wanna be hilarious. Point is, this is silly.

Link to comment
Share on other sites

Just want to add that I'm experiencing this same issue since the last iCUE update with my M65 RGB Elite mouse.  I use the sniper button for extended periods and having my DPI change is ruining my gameplay. Corsair, please investigate and revert whatever changes were made in the latest iCUE update.

  • Like 1
Link to comment
Share on other sites

I have the exact problem and it is driving me nuts! Yes only started after the most recent iCue update and I’m using a m65 Ultra wireless. I can confirm it occurs after holding the sniper button for 5 seconds and then it sticks the DPI. It does this as well with my m65 Elite.

  • Like 1
Link to comment
Share on other sites

I FOUND A SIMPLE SOLUTION:

This sniper button getting stuck and messing up my shots was annoying me so much that I decided to look for a solution. I discovered that you can get rid of the "stuck after 5 seconds" behaviour, so that the button works exactly like before. I did this on iCUE 4.18.209 using an M65 Ultra Wireless.

These are the steps:

  1. Open iCUE and select your mouse
  2. Go to Key Assignments and click + to create a new assignment
  3. For assignment type select Mouse, for Key press your sniper button
  4. For Remap, also select the sniper button, then open the advanced tab
  5. Activate "Retain original output", and select "while pressed" in the dropdown.

I hope this fix works for you as well as it did for me. Please let others know if it works for Elite and Pro too, as i can't confirm that yet.

corsair fix 1.png

corsair fix 2.png

  • Thanks 4
Link to comment
Share on other sites

5 hours ago, shlingleman said:

I hope this fix works for you as well as it did for me. Please let others know if it works for Elite and Pro too, as i can't confirm that yet.

I have just arrived home from a 13 hour shift 2 1/2 hours away in Savannah but this seems very promising. I'll play some tanks tonight and report back. For continuity, I'm in the M65 Elite RGB.

This may be the king of workarounds. Thank you for the work.

  • Like 1
Link to comment
Share on other sites

So I configured it the way you pointed out and now it works sometimes and not other times. I'm gunnuh mess with it though, this has promise.

  • Like 1
Link to comment
Share on other sites

7 hours ago, shlingleman said:

5. Activate "Retain original output", and select "while pressed" in the dropdown.

Okay, so I undid that option and everything seems back to normal. Apparently as long as I disable the background use of the button it seems to work again. So that may be a clue for the solution of the M65 Elite RGB.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

I followed the instructions and like Beefy1223, I found that the solution worked better if I did not select "Retain original input."

Thank you to Beefy1223 and Shlingleman for posting and solving this problem!

  • Like 2
Link to comment
Share on other sites

10 hours ago, Kindjal said:

I followed the instructions and like Beefy1223, I found that the solution worked better if I did not select "Retain original input."

Thank you to Beefy1223 and Shlingleman for posting and solving this problem!


Now lets hope that Corsair can follow up and determine why the firmware on certain mouse types are screwing up with the new software version.

  • Like 1
Link to comment
Share on other sites

I just played with the workaround... I have the Nightsword and instead of going to advanced I did what Beefy was talking about and left it on the "Selection" tab and just chose "Sniper" because for me the Drop Down on the "Advanced" tab once "Retain original input" was selected did NOT appear... (I don't know why or which of these 2 solutions worked for that separate issue but I... 1.) Repaired the Installation and 2: Used a new (supplied by CUE) Mouse profile "NIGHTSWORD RGB HW 1" as sen in upper left corner, I know that sometimes certain features and Dropdowns are Disabled or won't even show when in a "Default" profile).

2021-12-27.thumb.png.1d5d72f0939f91f927df1ac777e419f2.png

 

The above setup I tested with a 20 second hold and the DPI returned to its original 1750 from 400.  WooT!

  • Like 2
Link to comment
Share on other sites

  • 3 weeks later...

i will have to give a try.  just got a m65 ultra wired mouse.  the fix i found that worked was just exiting the software and letting my mouse use its onboard memory.  however with the ultra (not sure about the other m65 versions) it has a tilt option that you can assign as well and when doing this that function gets disabled when software is exited.  

but i also noticed when using the mouse with software open that when i press and hold the sniper button everything gets laggy.   but if this works and some how i get the laggy part fixed it would be nice to use the software so that i can use my sniper button how i am supposed to as well as the tilt function.  just to bad this is the work around and not something simple like a toggle button to select.  and that it was set up to do this instead of us picking it as an option.  mainly because if i wanted to keep the sniper dpi, i would just simply press my dpi up button (as i set my button to go to a higher dpi).  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...