Jump to content
Corsair Community

Rm850x trips on boot


Recommended Posts

Recently built a new pc with a ryzen 5800x, msi b550 a pro and red devil 6900xt ult. I ordered an rm850x but due to shipping delays i assembled my rig with my old cx750m and it worked flawlessly. When the 850 arrived i installed it and the board, fans, and gpu light up for a second then a click from the psu and it shuts down. Figured after some troubleshooting it was doa and returned it for another and same thing. Am i an idiot and doing something wrong cause theres no way i got two doas 

Link to comment
Share on other sites

The cables should be compatible between the CX-M and the RMX, but just in case, did you only use the cables supplied with the RM-X?

You did not forget any cable? the EPS one for the CPU for example, going from semi modular to modular ?

If it doesn't instantly trips, but takes a second, it's possible it is not short circuit but overcurrent protection. maybe if you have RGB going on, try to unplug the power to it, in case some wires were damaged during the swap.

Have you tried going back to the CXM again? it works? (to possibly rule out a damaged or pinched wire)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...