Jump to content
Corsair Community

corsair virtuoso xt bluetooth phone connections drops randomly


Recommended Posts

Hey i am using the corsair virtuoso xt with my pc with 2.4ghz and my iphone 12 pro over bluetooth. randomly, i hear the bluetooth doooduum sound and my phone connection is lost. i can push the bluetooth button on headset for a short moment and the connection is back very fast. sometimes its even happend while i am in a phone call, so i guess its no energy saving feature from bluetooth. 

i disabled sleep mode into icue. it even happend while connected wired (charging). i have no clue, what i can try.

Link to comment
Share on other sites

  • Corsair Employees
8 hours ago, ex2j said:

Hey i am using the corsair virtuoso xt with my pc with 2.4ghz and my iphone 12 pro over bluetooth. randomly, i hear the bluetooth doooduum sound and my phone connection is lost. i can push the bluetooth button on headset for a short moment and the connection is back very fast. sometimes its even happend while i am in a phone call, so i guess its no energy saving feature from bluetooth. 

i disabled sleep mode into icue. it even happend while connected wired (charging). i have no clue, what i can try.

Hey ex2j, sorry you're experiencing this issue. After possibly updating your phone and Bluetooth settings (check the privacy settings as well). You can try soft resetting your headset. 

To soft reset your headset make sure your mic is plugged in:

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset to wired mode and then back to wireless mode.

Another issue could be that the headset isn't charging all the way or isn't charged enough so its dropping itself off cause of battery issues. If that's the issue please let us know. Hope this helps. Please keep me updated. 

Link to comment
Share on other sites

  • 3 months later...

sorry for late answer. i still have this problem. my bluetooth device(smartphone) works fine with other bluetooth headsets.

 

i tryed your softreset but didnt notice anything happens. is there any feedback for it work? I didnt need to pair it again with phone or wireless dongle

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...