Jump to content
Corsair Community

Virtuoso SE Battery problem


Recommended Posts

Im having the followin trouble with the VIRTUOSO SE and following versions of firmware...  i keep getting this "critital battery indicator even when i've been charging the headset for a while and yes ive tried different amounts of times and it keeps getting this bug, the device works fine but i dont know when the battery is really low until it auto turns off because of the battery runing out of charge... ive tried to force update both the dongle and the headset but the option is allways showing up greyed 

image.png.19e1ee04b9685a762b699f4b15c99d33.pngimage.png.d7b97f377b885b4da9246263ee2037af.png

Edited by tincho004
Link to comment
Share on other sites

  • Corsair Employees

Hi tincho004,

We're sorry for your experience with our product, first off.

Try soft resetting the headset by holding down the mute button for ~15 seconds while the headset is still on. It should shut off on it's own when done correctly.

This disconnects and then reconnects the headset's battery, which can help with battery-related issues such as this. Please try a soft-reset and let us know your results.

Link to comment
Share on other sites

Hello, ive tried doing what you told me but it doesnt work, still showing critcal battery charge when it lasts for hours like that.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...