Jump to content
Corsair Community

Ironclaw RGB not working on reboot


Recommended Posts

Mouse refuses to work wirelessly after boot up or a reboot on my laptop. Need to unplug the USB Wireless Reciever and plug it back in to get it to work. Both mouse and reciever are seen by ICUE. Tried mouse on desktop PC that also has ICUE installed and did not display the same issue and seemed to work normally.

Tried resetting and re-pairing the mouse but thad also did not help. The issue seemed to start after a firmware update. Your help would be greatly appreciated.

Did some more testing with the laptop. Mouse works fine in UEFI BIOS. However it does not function in Windows nor when I tried an Acronis Boot CD (Linux Based). The Acronis Boot CD however did register the mouse clicks, Windows does not. Removing and re-inserting the dongle fixes the issue until the next reboot.

Windows 10 Pro version 21H1 OS Build 19043.1387, Dell G3 15 3500 Laptop, Intel UHD Graphics and GeForce RTX 2060

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...