Jump to content
Corsair Community

HS80 Background Noise Problem


Recommended Posts

I just bought the headphones and reading on amazon reviews other pc users also have the same problem, that is, if ICUE is installed when something is playing there is a horrible background noise, if I uninstall ICUE it disappears and the headphones are phenomenal . I was forced to return for this issue. Has anyone found a solution to this?

Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees

Sorry to hear you experienced excessive background noise. Do you remember if sidetone was enabled?

Unfortunately, since you no longer have the headset, we cannot troubleshoot. For any users that come across this thread in the future, please attempt a soft reset. We strongly encourage users that are experiencing any issues or have any questions to reach out to our support here, they will happily take care of you.

Link to comment
Share on other sites

5 minutes ago, Corsair Albert said:

Sorry to hear you experienced excessive background noise. Do you remember if sidetone was enabled?

Unfortunately, since you no longer have the headset, we cannot troubleshoot. For any users that come across this thread in the future, please attempt a soft reset. We strongly encourage users that are experiencing any issues or have any questions to reach out to our support here, they will happily take care of you.

On / off sidetone the noise was always there, the only solution was to remove icue

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...