Jump to content
Corsair Community

my corsair harpoon wireless is only showing as receiver on iCue after updating it


Recommended Posts

My harpoon is only showing as the receiver on iCue. After i updated the mouse it completely stopped working. I tried pairing it with the receiver again but i cant because my usb is broken. I've tried everything i could think of and everything recommended on the forums but nothing has worked. The receiver shows its updated to v. 5.4.99. I don't know if that's for the mouse too or just that. It was working fine before i updated it, if there is any way to reset the mouse that would be helpful.

Screenshot (35).png

Screenshot (36).png

Link to comment
Share on other sites

  • 2 weeks later...
On 12/15/2021 at 11:39 PM, Corsair Angie said:

Hey manekiosu, sorry I'm a little confused so I just need a little clarification. Your USB ports are broken so you can't update your USB dongle for your mouse? (But you also need to update the mouse too right?)

the USB wire for the harpoon is broken. so when i updated the mouse it wasn't connected with the wire, but the dongle instead. so after the update when i connect the dongle it only shows as the dongle and not the mouse. the mouse worked before the update, only the double click issue. i forgot what the update that ruined it was so i cant help with that. i also cant re pair them because i don't have the USB wire, i do have other wires that can connect but they don't work with the mouse. i also only got to update the mouse so i don't know if they're updated to the same version.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...