Jump to content
Corsair Community

Dominator DDR5 - XMP, stability, and lessons learned


Recommended Posts

Hey everyone,

     I've seen a couple of threads regarding issues with Dominator DDR5 timings and stability, and thought I'd share my experience in case it may provide some small bit of assistance.  First, some background on the system components I'm working with.  I pre-ordered an i9-12900K during the Alder Lake launch, and paired it with an Asus ROG Strix Z690-E motherboard.  I was fortunate enough to acquire some Dominator First Edition (FE) memory when that launched, along with decent storage and cooling options.  There was a minor hiccup with the AiO, but got ironed out fairly quickly.  Onto the build!

     I started off the build by backing up profiles and swapping the previous components into my wife's case as a trickle-down upgrade, and made sure there were no "fit" issues with my Meshify S2 case - I knew the Dominator memory was taller than average and went with a 360mm cooler instead of the 420mm, and everything looked to fit as expected/intended.  The biggest issue with assembly was routing the custom sleeved cables I ordered from Titan Rig (ModOne); I used those, because I wanted to upgrade from AWG 18 to AWG 16, and being able to choose the color for each sleeve allowed me to make my own pattern.  Measuring ahead of time made the cable routing process much easier (and kept the cost down slightly), especially as I'd expected them to be slightly stiffer due to the sleeving and thicker wires.

     Finally, it was time to boot this beautiful beast up!  And that's where things started to go a little sideways, due to a combination of defective hardware and my own missteps.  The motherboard shipped with bios version 0502, which I promptly updated to 0702.  I went through and updated various bios settings to what I remembered using from previous builds, and proceeded to the Windows 11 install process.... and the keyboard/mouse locked up almost immediately.  I verified XHCI settings, legacy settings, and so forth, and still no luck after multiple reboots and web searches on my tablet.  So, it was time to start troubleshooting - I pulled all USB devices except for the keyboard & mouse, and still no luck.  Time to go under the hood... decided to run the built in memtest86, and started getting errors almost immediately.  Shut everything down, and pulled all but one DIMM - I was still getting memtest errors in slot A2, so I moved it to B2, where it passed the "stock" (tests 1-9) 4-pass check.  Tested each DIMM in both of the FE sets in slot B2, one by one.  All passed the 4-pass test with the XMP II profile enabled.  Next, I used one DIMM to check each slot, and found slots A1 and A2 were bad - A1 was so bad, the bios menu showed up as 1/3 Japanese, 1/3 French, and 1/3 blank - the system completely locked at 27% of test #3 (pass 1), and I shut 'er down after waiting 30 minutes to see if it would move.  Reached out to Newegg and got authorization to RMA it, with the replacement arriving earlier this week.

     Backed up the bios settings to a USB drive and got the replacement motherboard swapped in without too much fuss (extra set of hands helped hold things out of the way).  Booted right up with a DIMM in A2, so I updated the bios from 0502 to 0702 again and restored the backed up settings.  Restarted, and everything looked to be running smoothly so I shut everything down again and installed the second FE set.  Everything still appeared to be working well, except for that li'l voice in the back of my head saying "are you sure....?"  Figured I'd do another memtest run on the full 64 GB of RAM while I watched Thursday night football, still using the XMP II settings.  First two passes completed without a hitch, but it pulled an error in passes 3 and 4 (one error in each).  Compared to what it was pulling on the previous motherboard, that's way better - but it should be zero errors.  And that brings us to today.  After sleeping on it, the next things I want to try are a slight bump to the voltage (from 1.25v to 1.2625v), and if that doesn't work I'll try dropping the frequency from 5200MHz to 4800MHz.  Once I'm done with work I'll give those a shot, and report back on how it went.

Lessons learned:

  • With the launch of a new chipset version, processor line, and memory specification, there's going to be some growing pains.  Hopefully, future bios updates will smooth this out over time.
  • Using two 32GB sets of Dominator FE may not have been the best idea, but there wasn't a 64GB option available at the time.  In hindsight, the 2x32 GB C38 kit might have been the better choice, but I don't remember it being available at the time.
  • Take the time to test each DIMM and memory slot, one at a time, before moving on to OS and software/game installation.  
    • This is important for Windows 11, especially if you end up having to replace certain hardware and you have BitLocker enabled!  At the least, a motherboard swap (even for the exact same model) will result in a hardware ID mismatch that requires re-activation of Windows, and resetting any Hello authentication methods.  Worse case, you'll lose access to a drive with Bitlocker, unless you've got the key backed up/printed out.
  • Be patient, and don't make assumptions.  I was leaning towards thinking the memory was bad, based on the POST codes from the original motherboard... until I started testing, and realized my assumptions were incorrect.  
  • Start off with the more conservative XMP II settings before pushing it further.  I'm not doing a full-on OC build, so can't help much beyond that.

Hope that helps!  Happy building, and I'll report back on if the voltage tweaks or frequency changes iron out those last, pesky errors!

Link to comment
Share on other sites

Alrighty, I've started testing.  First up, was updating from bios version 0702 to the newly release 0803 (released 12/3/21, https://dlcdnets.asus.com/pub/ASUS/mb/BIOS/ROG-STRIX-Z690-E-GAMING-WIFI-ASUS-0803.ZIP)

Kept all bios and memory settings the same (XMP II profile), and ran memtest again:

memtest_12-3-21_v1.thumb.png.4c32e4d69d5cbaca090437ea0cef8b4d.png

Not too bad, but I want to get it to 100% pass, before I run the complete 13 test cycle.  Next, I'll swap to the XMP I profile and see what impact that has.

 

Link to comment
Share on other sites

For the second test, I switched to the XMP I profile, with the same 9 test setup.  Definitely a step in the wrong direction, as the system completely halted at 50% of pass #4 with 19 errors; couldn't save the report, so here's a screenshot.

memtest_12-3-21_v2.thumb.jpg.cbc79ed03568a2234594e7bb39308f78.jpg

Link to comment
Share on other sites

Finished up a third test late last night/this morning.  Went back to the XMP II profile from the first cycle, and bumped VDD/VDDQ voltage from 2.25 -> 2.265.  For the next test, I'm going to bump up the VDD/VDDQ and memory controller voltage by 0.00625. 

memtest_12-3-21_v3.png.d019c6d907dcb7cea35371ca57a865ee.png

Link to comment
Share on other sites

Looks like bumping the voltage did the trick!  For this test, left it on XMP II, set VDD/VDDQ voltage to 1.275, and the memory controller to 1.25625.  I'd noticed that in the Bios Advanced landing page, the memory controller voltage was often running a little below the 1.25 setting.  Next up, I'll run the full 13 test cycle and we'll see if it remains stable.

memtest_12-3-21_v4.png.4acaeb327007f5fe106c75ec1754c6f3.png

Link to comment
Share on other sites

So I fudged around with this one for a bit...  I started off by lowering the VDD & VDDQ voltages back to 1.25, to see if it was the memory controller that resolved the initial errors.  Every time a test caught some errors I stopped it early, and bumped up the VDD & VDDQ voltages up by 0.005.... and ended up right back at 1.275 when it finally passed.  My hypothesis is either the number of 16 GB DIMMs (4), or the use of two First Edition sets, led to the need for a bit of extra voltage to maintain stability.  I did end up skipping the hammer test, because something occurred to me... the OS, apps, and games were installed before I realized memory errors were happening.  While I don't really want to, going to go ahead and wipe the drives and do a clean install to avoid any potential issues down the road.  

memtest_12-3-21_v5.png.9990d33e042562992e0211ecde682111.png

 

And with that, I think our story is pretty much done.  Happy building!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...