Jump to content
Corsair Community

New Keyboard, and I already have issues...


GeeGeeX57
 Share

Recommended Posts

Just got the Corsair K55 RGB PRO Keyboard.  It is wired.  

 

When using the shift key to type the symbols under the regular numbered keys, it doesn't work.  So, I type 78% (I am using my old keyboard now) and the % sign does not show up.  It does nothing.  I tried all the other symbols, they don't work either.

 

I got the ICUE software installed.  Nothing on there helps it. I did the FN + F4 hold for 5 seconds, nothing happens, not even a message saying it's been reset to factory default. I tried unplugging it, and plugging it back in again, nothing.  I tried unplugging it, holding down the FN + F4 keys while unplugged/and plugged in for 10 seconds, plugged it back in and released.  Nothing. 

 

I updated everything, including firmware.  Anything I missed before I contact Corsair for a refund?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...