Jump to content
Corsair Community

Commander Pro Not Showing up on iCUE 4


NickyG
 Share

Recommended Posts

I recently installed a commander pro into my build with the following core specs: 

* CPU: AMD Ryzen Threadripper 3960x

* GPU: NIVIDIA GeForce RTX 3080

* Motherboard: ASUS ROG Zenith II Extreme Alpha 

* NZXT Kraken Z3 AIO

 

I recently had my 6 LL120 fans connected to my corsair RGB Hub to control the lights and the 4 of the 4pin fans going directly into moBo and 2 going into a splitter off my AIO (not the best but it worked for the most part). The RGB Hub then connected into a corsair lightning node pro which then connected via USB into the mobo. 

I wanted to control my fan RPM so I got a Commander Pro (CoPro) to control RGB and RPM. However I just can't seem to get either the RGB hub or commander pro to pop up on the iCUE software. I feel as if I have tried everything and I am hoping I have missed something. I have attached a diagram of what my wiring looks like (minus the LED Strip). I have tried the following:

* Updated BIOS

* Tested on iCUE 3 and iCUE 4

* Have reset the CoPro according to the website specifications 

* I have changed USB ports, SATA endpoints, PSU ports, to see if its damaged however the fans are spinning up and the RGB are lighting up

* I have removed the iCUE correctly (removing all corsair files in the registry and then uninstalling the application) 

* I know the CoPro is working cause the green light flashes when the PC is turned on. 

 

I have been told to look into getting an NZXT USB hub? Don't know if that will solve my issue. I really don't know what the problem is and I feel like it has to do with a driver for the commander pro but I don't know what one. I have raised a ticket with Corsair but I have been told it takes some time. Thought I'd try here. 

Really would appreciate some help on this topic. 

Link to comment
Share on other sites

3 hours ago, NickyG said:

I have been told to look into getting an NZXT USB hub?

Most likely that or any other powered USB hub and that is the heart of the issue.  The AMD boards starting with x570 went to a lower spec on the USB 2 output voltage at that port.  Most AMD owners will see this as frequent disconnects, but some devices need more power than others.  The Commanders and the Platinum coolers are the most affected, likely because they need more power on that line.  You were probably getting away with it on the LNCore that needs less.  The 5v lighting for the fans comes from the RGB Lighting Port and SATA/PSU directly, so they light up.  However device recognition and control is through the USB port back to the software and that is where you are hitting a dead end.  

 

It's not impossible for there to be another factor involved, but 99% of these come back to this issue rather than complex driver/device failures.  Sometimes we see a user with a brand new MB forget to install the chipset software (with USB drivers) and this happens, but that seems improbable since you already had the LNCore working for some time.  Those types of issues tend to be universal and the disconnect/missing device stuff is the power issue.  You can connect the LNCore back in just for a moment to prove the system can read the port.

 

Whichever brand/device you pick, it needs to have a SATA power delivery.  Most of these have a small circuit board.  Do not get a two way USB splitter.  That only amplifies the problem.  Either way, this should be less than $20 USD.  

Edited by c-attack
  • Like 1
Link to comment
Share on other sites

I have a commander pro stuffed into my rig. I also have a separate power cable to that unit and my H115i PRO RGB AIO water cooler.

By using a single power cable to the Commander Pro and H115i I have as much power as possible to the hardware.

This makes the hardware work well in my box and I use an MSI X570-A PRO motherboard

 

 

  • Like 1
Link to comment
Share on other sites

9 hours ago, NickyG said:

Absolute Legend! The USB hub worked a treat. For those that encounter a similar issue, I ordered an NZXT USB hub and it has resolved my issue. 

I have USB splitters but I have not found ones with supplemental power. The Commander Pro does have power which does have advantages. The H115i also has fan headers to the Commander Pro is not critical.

This is why I went for Corsair parts as they seem to work fine together.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...