Jump to content
Corsair Community

Dominator DDR5 not detected in iCUE


Recommended Posts

I updated the bios on my ASUS z690 maximus apex two days ago and now the ram is not being detected in iCue. RGB is stuck on watercolor. I do not not use Asus Aura. It was working just fine prior to the bios update.

BIOS Version/Date: American Megatrends Inc. 0702, 10/22/2021

Ram kit: CMT32GX5M2B5200C38

Link to comment
Share on other sites

Solution found.

Disable SPD write in bios.  SPD Write = FALSE

Link to comment
Share on other sites

  • 1 month later...
On 11/20/2021 at 7:15 PM, qcarmbender said:

Solution found.

Disable SPD write in bios.  SPD Write = FALSE

Would greatly appreciate assistance if someone would please outline the path through the Z690 UEFI menus to navigate to the SPD Write = FALSE option?  I cannot locate this after walking through UEFI menus.  I have a similar issue with Dominator Platinum DDR5 5600-C36 2x16Gb DIMMs’ RGB in cycling LEDs in default rainbow mode and not listed in iCue’s latest download version.  I have enabled XMP2 profile on these DIMMs — does that block access to the SPD Write UEFI setting?

My H150i Elite and LL120 fans are all readily recognized and functional with iCue.  Just the DDR5 is not listed to allow RGB control.

Link to comment
Share on other sites

Ok — found it.  On Z690 UEFI bios I did not know it is possible to enter search terms.  “SPD” search revealed “SPD Write Disabled” bios setting.   Toggled this from TRUE —> FALSE, restarted, and now iCue detects the Dominator Platinum DDR5. 

Link to comment
Share on other sites

I had the same problem with my build, memory not showing up in iCUE. I have the Asus z690E bios version 0811, GTX 1080, H150i Elite LCD,  x7000 RGB case, K70 RGB, M65 RGB and DDR5 Dominators. Everything but the memory showed up. Toggled SPD Write Disabled from true to false and it was fixed.  I could not find the setting, trying the search option was the key to finding the setting. Thanks!

Edited by paesan
Link to comment
Share on other sites

everyone seeing the XMP profiles as well? I have a ROG STRIX Z690-G GAMING WIFI with latest 0811 bios, and while the memory is detected, I can't see/modify xmp profile, and support hasn't been able to help much yet? Wondering if its widespread or someone has ideas? I have uninstall/reinstall, triple verified bios settings and disable other resident programs (Asus gputweak, armoury crate...)

Link to comment
Share on other sites

  • 3 weeks later...

Thank You. Worked on Z690 Apex and Extreme, on Corsair 5600 MHz CL36 and 5200 MHz CL38. The SPD hack in BiOS/UEFi.

Link to comment
Share on other sites

  • 2 weeks later...
On 12/29/2021 at 11:58 PM, Dude_Bro said:

Ok — found it.  On Z690 UEFI bios I did not know it is possible to enter search terms.  “SPD” search revealed “SPD Write Disabled” bios setting.   Toggled this from TRUE —> FALSE, restarted, and now iCue detects the Dominator Platinum DDR5. 

Yeah the search feature on Asus Z690 boards is huge, had to use it several times on my ProArt board.

Link to comment
Share on other sites

On 12/29/2021 at 11:58 PM, Dude_Bro said:

Ok — found it.  On Z690 UEFI bios I did not know it is possible to enter search terms.  “SPD” search revealed “SPD Write Disabled” bios setting.   Toggled this from TRUE —> FALSE, restarted, and now iCue detects the Dominator Platinum DDR5. 

Same issue here. ASUS Z690 Prime Wifi D5. The Dominator RAM initially displayed in iCUE when I had the stock BIOS (~v0404, iirc.). I updated the BIOS to v1008 and the RAM disappeared. Making this change fixed it.

+1 for search in UEFI!

Link to comment
Share on other sites

I have the Z690 Extreme, and cannot get the Dominator RAM to display with BIOS 0811. I tried the "solution" but after reboot iCUE hangs on startup and crashes. Repeated attempts to open it fail with the same problem, it opens, hesitates and closes. Any ideas? 

Link to comment
Share on other sites

45 minutes ago, starcatman said:

I have the Z690 Extreme, and cannot get the Dominator RAM to display with BIOS 0811. I tried the "solution" but after reboot iCUE hangs on startup and crashes. Repeated attempts to open it fail with the same problem, it opens, hesitates and closes. Any ideas? 

Nevermind, I resolved the issue, I uninstalled iCue and reinstalled it. 

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
  • 3 months later...

My Cosair dominator platinum RGB also was not showing in the latest version of iCUE v4.26.110. My MOBO is also ASUS ROG Strix Z690-E. Another device not showing was the Commander Core XT.  Above a possible fix was the BIOS to make SPD Write Disabled toggled from TRUE to FALSE. I will try it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...