Jump to content
Corsair Community

Corsair iCUE H150i RGB PRO XT - Fans running in full speed


Recommended Posts

Hello All,

I've a Corsair iCUE H150i RGB PRO XT purchased 15.09.2020 in my setup.

It was working fine until today. While I was surfing with google chrome (pc was almost idle) all the 3 H150i fans started to run with full speed. I've tried some troubleshooting and no luck. Here what I did;

Uninstalled iCUE software with complete settings. Reinstalled and created new profiles. Tried zero RPM or quite mode.

Reset the MOBO bios to defaults. (Asus ROG MAXIMUS XII HERO)

Removed all the hardware components from chassis and reinstalled again including all the cables. Also did some cleaning :)

Make sure that all the cables for H150i installed properly.

Tried to change USB output for H150i. 

I don't know what I can do more for troubleshooting. Any help will be appreciated. Anyone had this issue before?

 

 

 

mysetup.jpg

Edited by nofearman
photo correction.
Link to comment
Share on other sites

After I've reinstalled iCUE it shows you've a new firmware available for H150i but it was already in the new version. I've clicked upgrade but it got failed as well.

 

image.thumb.png.6fa34b6c7c0f33bea45e104718fcae1f.png

Link to comment
Share on other sites

I've rebooted my computer and looks like icue can't read the current firmware version from the hardware. all the cables are working correctly.

 

image.thumb.png.6444a9907a909a50095025e14311cb71.png

Link to comment
Share on other sites

Now it stopped seeing the device completely and rgb on the pump is not working as well after the restart.

 

Link to comment
Share on other sites

I had a similar problem with my H100i RGB Pro XT except my fans were stuck on low and I was getting 100 degree CPU temps and throttling.  On a whim, I manually updated the firmware using the file I found at the link below and now everything is working perfectly again.  In my case, I already had the same firmware version, so I guess something had gotten corrupted.  If yours isn't even recognized by USB now, you may not be able to even manually upgrade.

Here's the link: 

 

Link to comment
Share on other sites

My issue is not resolved. iCUE software cannot see the AIO anymore. I can't upgrade the firmware. LEDs are not working on the pump as well. There is a USB reconnects sound coming from the windows continuously.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...