Jump to content
Corsair Community

Is the ST100 what is causing my random usb disconnects??


Recommended Posts

Everytime I restart my PC it asks me to update the firmware to 0.04.106. I've done it several times and it doesn't seem to stick.  I've also noticed ever since I got this stand, all my corsair peripherals would randomly disconnect/reconnect.

All the googling it doesn't look like anyone found a definitive solution. In the mean time I just have my stand unplugged. I don't use it for audio or anything.

Imagine such a faulty product making me think I was suffering from the B550 usb disconnect issues when it was not my mobo at all.

Edited by id3alistic
Link to comment
Share on other sites

13 hours ago, id3alistic said:

Everytime I restart my PC it asks me to update the firmware to 0.04.106. I've done it several times and it doesn't seem to stick.  I've also noticed ever since I got this stand, all my corsair peripherals would randomly disconnect/reconnect.

All the googling it doesn't look like anyone found a definitive solution. In the mean time I just have my stand unplugged. I don't use it for audio or anything.

Imagine such a faulty product making me think I was suffering from the B550 usb disconnect issues when it was not my mobo at all.

same thing here... annoying...

Link to comment
Share on other sites

  • 2 weeks later...

Update. I bought a powered USB hub which my ST100 is now connected to. There has been no issues with usb disconnects in over a week. Also no more firmware update notifications.

Not too big of an issue since I wanted to get a powered USB hub anyways.... but a pretty horrible workaround for those who do not plan to get one.

Edited by id3alistic
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...