Jump to content
Corsair Community

LCD Upgrade kit USB issue.


Recommended Posts

I had trouble in the past with not being able to have iCUE recognize internal USB device's that aren't connected directly into the motherboard (Asus rog maximus xi hero WIFI z390 on latest bios) I had the Elite Capellix in one USB slot and the commander pro in the other, Even when I upgraded to 9 QL120 fans with 3 in the Capellix included core and was going to hook the other 6 into the commander pro I ran into the issue of needing another USB plugged in because the QL120's need the lighting node core plugged in for lighting and plugging it into the commander core USB iCUE wouldn't see it, Only if I plugged it directly into the motherboard, So then I purchased the commander core XT so that it would eliminate the need for the lighting node core and everything worked fine. Well now I just purchased the LCD upgrade kit not knowing that it now has 2 USB headers that need to be plugged it and I am running into the same problem with it not being recognized unless both are plugged  into the motherboard, They even included a USB splitter with the LCD upgrade kit but it won't recognize that or having one plugged into the motherboard and the other in the Commander core XT, When I plugged both USB plugs from the Capellix and LCD upgrade kit directly into the motherboard it works fine but then that leaves the Commander core XT unplugged, Tried a bunch of different combinations but its either one device or the other (Capellix and LCD kit or Capellix and Commander core XT) Sorry for the wall of text but maybe some of you pros know thanks.

iCUE4 ver.4.17.244 All devices updated.

RM850X Power supply

Link to comment
Share on other sites

Like a lot of people, you may need a powered internal USB 2 hub.  These are relatively inexpensive (about $20 USD) and typically can handle 3-4 USB internal devices.  It needs to have a SATA connector for power.  That is the essential difference between it and a passive splitter, like what comes with the LCD upgrade kit or when running other devices through the Commander Pro's USB ports.  

 

This is a common issue for AMD B550, x570, and x470 (with x570 BIOS updates), but not for Intel and not for Asus Z390.  I am a little surprised and I ran my Formula Z390 with dual Commanders and all 4 passthroughs populated.  Typically it's lack of MB voltage on the AMD boards, but not sure what to make of this on the Asus Z390.  

Edited by c-attack
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...