Jump to content
Corsair Community

Corsair K70 Lux Keyboard malfunctioning


Recommended Posts

Hi guys,

 

for the last three days I've been experiencing something I've never dealt with or witnessed before. So four nights ago I left my pc running cause I was downloading a game and it was going to take a while to finish. The following morning I got up and when I went to the pc it seemed like someone had tried getting into it as I could see that someone tried typing in the password. I asked everyone in my house and none of them had tried to go on it. I then tried to sign in and check on the download and for some reason my keyboard wasn't typing which is when I realised that someone had changed the language preset (the one on the bottom right corner) from English to Assyrian. I changed it back to english and then got into the computer. I then went to check on the download and noticed the pc was behaving very strangely.

 

I decided to run a game of shogun 2 and while in game, I pressed the escape key to pause the game and it was just taking me back to the desktop. Wasn't closing the game just minimising the window. I got back in the game and tried pausing the game again only for the same thing to happen again. I gave up and closed the game and when i was on the desktop i noticed that everything started going crazy. The language setting changed by itself back to Assyrian from English. The little menu that pops on the desktop when you right click in a blank space kept popping up even when my hands were not on the mouse and keyboard, the windows menu kept coming up by its self. I tried going on to Chrome to look up a fix only to find that my keyboard wasn't typing either and that random buttons were being clicked (obviously not by me). I deduced that it was my keyboard because when I unplugged it everything stopped freaking out. I decided to look up on my phone if there are any fixes. I've tried unplugging, holding down the ESC key and plugging back in then letting go after 5 seconds which would reset the keyboard but not fix the issue. I tried switching the bios setting on the manual swither on the keyboard from 1-5, still didnt work. Even when i switched it all the way to "BIOS", it would seem like it was working for about a minute or two before freaking out again. I tried deleting the drivers then restarting the pc for windows to redownload the drivers automatically on boot but still didn't work.

 

I've tried every fix i could find and i would really appreciate if anyone here could help. Also not sure if this might be helpful or not but when i went into the device manager to delete the keyboard drivers there were 3 and i believe they were all titled something like "HID Keyboard...". Something along those lines. And when i deleted all three and restarted and went back into the device manager all three were right back there.

Link to comment
Share on other sites

  • Corsair Employees

Hello AssyrianWarrior97,

If a clean reinstall of iCUE does not resolve the issue, try repairing iCUE.

Before repairing iCUE, delete the “Corsair composite virtual input device” driver.

Open Device Manager.
Select Human Interface Devices.
Right-click Corsair composite virtual input device and select Uninstall device.
Tick the Delete the driver software for this device checkbox, and then click Uninstall.

Delete_driver_checkbox.png

Rerun the installation file for iCUE and select Repair.
(iCUE 3)
icue_installation_repair_option.png
(iCUE4)
mceclip1.png

Follow the instructions for repairing iCUE.
Reboot your PC.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...