Jump to content
Corsair Community

Upgraded to Windows 11, K63 and Dark Core SE no longer connect wirelessly


Recommended Posts

MSI MPG Z490 motherboard (updated to latest BIOS)

iCue updated to latest

Dark Core SE mouse on latest firmware (it will connect but has a range of like 3')

K63 keyboard not on latest firmware because it won't connect at any range.

I tried completely uninstalling/reinstalling iCue, to no avail.  There are no other wireless peripherals that could be interfering.

 

Prior to updating to Win 11, I had Win 10 and everything worked swimmingly.  I game from my couch, about 10' from the tower, so while both work wired I would rather not have 2 USB cables strewn along the way.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...