Jump to content
Corsair Community

ICUE with corsair m55/Glaive locking programs


TRH3112
 Share

Recommended Posts

This will be somewhat long but stick with me, so this is an odd issue that developed today, nothing new on my PC same as always and I did not have this issue yesterday. ICUE is some how locking out any program I open, let me explain in a little more detail since "Locking out" is a broad term.

I have YouTube open currently in chrome, Discord and League of legends client, I run ICUE since i have various corsair parts, whenever I press MB4 to go back on a YouTube page etc. all programs that are open freeze, YouTube keeps playing but I cant close the window I cant pause, discord I'm still talking and hear people but I cant type or disconnect from a call, league I cant que for a game.

I can open new programs like steam but once steam opens it sits there and I cant click Library or anything, my mouse still moves no issue, I have two different mice a Corsair Glaive and an m55 both cause the issue, when I press MB4 everything is stuck where it currently is and task manager even locks up.

I did not know what this was at first since it came out of the blue, so I started my PC in safe boot and turned off all start up apps and opened them one by one to see what was the issue, once I got to ICUE it opened like normal all programs working fine but as soon as I pressed MB4 to go back a page everything locked. So I checked again restarted pc and opened just ICUE no other programs open and used file explorer to test the back button sure enough as soon as i did this explorer locked and I was unable to make the program do anything, no crash errors if i ctrl alt del i get stuck on the windows screen with a few options but cant interact with them.

I restored to a backup on an external HDD from about a year ago when the issue was not present, did fresh updates on everything and still the same issue persists. I tried also to set all my pc parts clock rate to default and this had no effect. I tried and confirmed this with both my Corsair mice, when ICUE is open if I press MB4 everything stops, I have the latest drivers for everything ICUE is up to date I tried different USB ports etc. Is this a problem for anyone else or is there a fix for this? since currently i cant have ICUE open at all or I lose functionality of my pc.

Note after 24 hrs pc is working flawlessly without ICUE open still same issue if i open the program i have to hard reset my pc.

Specs if needed:

I9-9900k

RTX 2070 super

32gig corsair veng rgb pro

2x 2TB Samsung 970 evo

asus z390-A mobo ( i have reinstalled ICUE without the asus aura plug-in thinking this was causing an issue, the issue still persists even without the asus aura plugin.)

be quiet! Straight Power 11 Platinum 1000W

corsair AIO 240mm

6QL 120s

K70

M55/Glaive for mouse

All temps and monitoring tools are completely normal aside from ICUE being a CPU hog when its turned on but yeah that's normal.

 

Edited by TRH3112
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...