Jump to content
Corsair Community

iCUE ELITE CPU Cooler LCD Display Upgrade Kit - unable to install


Recommended Posts

Hi there,

I have a ASUS - ROG Crosshair VIII Hero AMD motherboard. I also have a corsair icue h150i elite capellix cpu cooler installed.

I purchased the iCUE Elite CPU cooler LCD Display Upgrade kit.

I am unable to install the upgraded LCD display unit though because of corsairs own AMD CPU mounting brackets for the cooler. Because the new LCD unit is much bigger it wants to seat all the way down to the motherboard. With the current cpu mounting brackets it does not fit all the way down.

Is this just poor design?. I cant be the only one with this issue.

What are my options besides returning the LCD unit?

 

 

 
 

cooler1.JPG

cooler2.JPG

Link to comment
Share on other sites

Yes, I agree that the design is problematic. I was, however, able to mount mine on the AMD bracket. It took a bit of work to get it fully seated. And make sure that you add the screws.

Link to comment
Share on other sites

Same problem, using a H115i with the AMD mount. I took the bottom plastic shroud off the LCD. Snapped on just fine after I did that and it's held in place by the magnets and the connector. 

Edited by GWNewman1
  • Like 1
Link to comment
Share on other sites

You're welcome - I just now saw this haha. 4 screws on the bottom for anyone else looking. Take it off and it still mounts clean. 

Link to comment
Share on other sites

View without the shroud. I can't see it anyway with the glass panel on. I'd rather have a smaller cable though 🙂

 

IMG_0205.thumb.JPEG.aa214eb02bca7e60cdc0f21f8ba2be51.JPEG

Link to comment
Share on other sites

I had one more issue that came up after i initially turned on  my rig. I did check this prior but the display was coming up with a red exclamation and icue did not recognize it. I previously made sure iCUE was updated and updated the firmware as well.

Even though that was done this issue was still occurring. I had to go to https://www.corsair.com/us/en/Categories/Products/Liquid-Cooling/iCUE-ELITE-CPU-Cooler-LCD-Display-Upgrade-Kit/p/CW-9060056-WW#tab-downloads

And grab iCUE from here and install it over top of my existing. not sure why my other version of icue didn't find this new version when I hit check for updates.

Anyways all is well now.

Link to comment
Share on other sites

Aside from using an older CUE 4 version that does not support it, most of the red triangle issues have been physical connection problems.  Do a full shutdown and check the connection between the LCD top and the socket underneath.  A bump to the top with the power on is enough to set (!) off .  

Link to comment
Share on other sites

  • 4 months later...

I ran into the same issue where the unit was not seated properly while installing mine. I remedied the flaw by removing the pump head, took off the lower bracket causing me to not seat the screen properly and proceeded to slide back on the AM4 lower bracket until it touched the plastic skirt. Reapplied thermal paste and mounted the pump head back on. I had no issues with reinstallation. CPU is cooled perfectly fine even though the bracket was shimmied back a smidge, I was able to tighten down the pump head with no issues 

 

<a href="https://ibb.co/ZWHdFH6"><img src="https://i.ibb.co/ZWHdFH6/IMG-9120.jpg" alt="IMG-9120" border="0"></a>

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...