Jump to content
Corsair Community

VOID RGB Elite Headset not working


Recommended Posts

I purchased the wireless void rgb elite headset a few months ago and im starting to regret it. Initially i thought it was a charging issue, i would try to turn the headset on after a few days of not being used, and it wouldn't turn on whatsoever. I did some googling and found a method to reset the headset that worked the first few times. Hold the mute button down for 15 seconds and then press the power button and it turns on. This method worked the first few times i couldn't get the headset to turn on. I let the headset sit for about a week with no use and now it wont turn on even with this method. I have tried to force update as instructed in the post on this website for the headset being in bootloader. My PC will not recognize the headset to even allow the force update since it wont turn on. Im ready to throw these things in the trash and write off corsair forever as a trash brand. Someone please help

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...