Jump to content
Corsair Community

Corsair iCUE - LL120RGB fans


Recommended Posts

So here is my problem. When I first got the fans everything worked perfect. Then one day for no apparent reason only one of my fans were lighting up. I tried everything to fix it and nothing worked. I did every troubleshooting tip I could find online and nothing worked. Then one day, poof! They all worked again! Kept working for a while then, POOF! Down to only one light on one fan working. I saw one help video online that said to try dragging the led icons in iCUE to the other fan slots and mixing them up. Tried it, and POOF! They all turned on and worked again. Shutdown my PC and POOF! Down to only two fans lighting up. Then I noticed something. Whenever all three fans LEDs would start working again, they would quit after I shutdown my PC. I tried a clean install of Windows. I also had some success after I uninstalled the iCUE software and all its saved folders on my PC and reinstalled but each time I fix it, it is short lived. I just wish I knew exactly what was going on. I read other people having the same exact issue but can find NOTHING on the internet or the forums about an official fix. Finally decided to create an account and reach out to the support team because I am tired of my fans LEDs never working. PLEASE HELP 🙂

Link to comment
Share on other sites

  • Corsair Employees

Hey TheBerean, I'm sorry you are having trouble. Can you reply back here with the fan models as well as iCUE software version you are running? What Windows are you running (10/11)? Besides suggesting a hard/forcing a firmware update which I believe you already did and a clean reinstall of everything - I will try to help you here. Remember, you can always reach out to our support as well.

Link to comment
Share on other sites

11 hours ago, Corsair Angie said:

Hey TheBerean, I'm sorry you are having trouble. Can you reply back here with the fan models as well as iCUE software version you are running? What Windows are you running (10/11)? Besides suggesting a hard/forcing a firmware update which I believe you already did and a clean reinstall of everything - I will try to help you here. Remember, you can always reach out to our support as well.

CORSAIR - LL Series 120mm RGB

CORSAIR iCUE v3.38.61

Windows 11 - completely updated

 

Link to comment
Share on other sites

Interesting. Did you try disabling Windows Fast Startup? https://www.windowscentral.com/how-disable-windows-10-fast-startup (similar process for Windows 11).

Link to comment
Share on other sites

  • Corsair Employees
23 hours ago, TheBerean said:

CORSAIR - LL Series 120mm RGB

CORSAIR iCUE v3.38.61

Windows 11 - completely updated

 

The iCUE 3.38.61 software is not compatible with Windows 11. You will need to update to our latest version of iCUE 4 which is 4.16

Link to comment
Share on other sites

4 hours ago, Corsair Notepad said:

The iCUE 3.38.61 software is not compatible with Windows 11. You will need to update to our latest version of iCUE 4 which is 4.16

I did and it still will not work. Based on my research online, my problem is fairly common and there doesn't seem to be a clear fix. I now have the latest version. My problem is not a recent occurrence. My problem has been persistent since I purchased the fans over a year ago.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...