Jump to content
Corsair Community

PSU RM750i pcie power cable problem


Recommended Posts

I have the following power supply: RMi Series RM750i — 750 Watt 80 PLUS Gold Certified Fully Modular PSU

I just installed the following graphics card:

ASUS GeForce RTX 3060 Ti Republic of Gamers Strix V2 OC Graphics. (MFR #ROG-STRIX-RTX3060TI-O8G-V2-GAMING)

The card requires 2 x 8-pin pcie power connections. I tried using just one of the pcie power cable (with 2 x 2+6 connectors) but the graphics card shut down. I connected a second pcie power cable to the power supply. Now the graphics card has two separate pcie power cables. There is a red light next to each pcie power connector on the graphics card. Sometime one of these red light will flash indicating that there is a power problem. If I wiggle the pcie power cable with the red flashing light sometimes the light will go out. Does that indicate a faulty pcie power cable?

Another thing. There are two pcie power connectors on each pcie power cable. If I only use one does it make any difference which one it is?

Ed

Link to comment
Share on other sites

Update: I unplugged all the power cables from the power supply and plugged them back in a few times. No more red lights on the PCIe power connectors on the graphics card. The power problem at least for now seams to have gone away. Maybe the almost 5-year old power supply had some oxidation on the connector pins. Does that seem reasonable?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...