Jump to content
Corsair Community

iCUE not detecting Ironclaw Wireless


salafzan
 Share

Recommended Posts

Hi,

I can't get iCUE to detect my Ironclaw RGB Wireless anymore. This happened after updating to the latest version 4.16.194 and updating to the latest firmware where it was working until waking my PC from sleep. I've tried installing older versions (3.xx, 4.15.xx), but it's not being detected anymore. The 3.xx version explicitly says "No device detected" whereas the new interface doesn't tell you anything.

Things I've tried so far:
- completely uninstalling the driver for the mouse and virtual adapter

- installing the drivers manually (through Snappy Driver Installer Origin)

- completely removing iCUE and all traces I can find in program files, programdata,. appdata and the registry

- using the repair function of the installer

- installing different versions of iCUE

- connecting the mouse to different ports: front, back as well as through hubs (for testing)

- connecting through bluetooth, USB and the wireless dongle

Any advice would be appreciated. Any answers I could find on this issue did not help.

Edit:
To clarify:
The mouse is working fine, but the software is not.

Edited by salafzan
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...