Jump to content
Corsair Community

Unable to use K95 Platinum XT in BIOS or BIOS Startup


SiggsMeyer
 Share

Recommended Posts

Why would I not be able to use the K95 Platinum XT? I have searched around seeing if there is a solution to get it working and I can't seem to find anything, I've tried the F1 and Windows Lock Key, and the S and B combinations, to enter a "BIOS Mode" with no success. Though why the hell should I need to enter a BIOS mode to use a keyboard for it's most basic function in BIOS? Even when I get into the BIOS using another keyboard, it still never detects, even though the USB passthrough works perfectly fine for my mouse.

I have the keyboard plugged directly into my Motherboard and have tried both 2.0 and 3.0 ports, even making sure only the Keyboard USB is the only part plugged in. All with no success in entering BIOS with the Keyboard. I have the latest firmware version 4.22.30 installed. 

I have an older K95 Platinum that works perfectly fine to enter BIOS and BIOS options but, would rather not have to use it as it is old and falling apart at this point. I do not see why a $200 dollar keyboard can't even do the most basic functions of being a keyboard? I happen to go into BIOS often to make changes to RAM Overclocking and booting into other OS'.  It just doesn't make sense as to why it would not work or require a BIOS mode in order to use a basic standard that has been in use for at least 20 years and was available on their older Keyboards.

I have also sent a corsair support request and am waiting for a reply on that. I figured I would try getting troubleshooting support in the Corsair forums as well to see if anyone else has found a fix for this.

Very sorry for any rant, just frustrated.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...