Jump to content
Corsair Community

Sapphire 6800 XT Nitro+ RGB stopped working with Corsair


Titan777
 Share

Recommended Posts

I had it working perfectly for a while.

Now it does not respond to the ARGB cable connected to the GPU.

I tried both channels on the CoPro, tried multiple connection options, adapters, etc..

Nothing seems to work. Once I choose External Source in Trixx - the LEDs are stuck on the previous effect they had within Trixx.

Is the GPU ARGB connection dead? Should I return it for a new card?

Link to comment
Share on other sites

Any suggestions?

Link to comment
Share on other sites

6 hours ago, bluedevils477 said:

I had the same issue, I used a cable from PirateDog (or something like that) I connected to the Node Pro and ARGB header. It worked for a little then the LEDs just cut off. I couldn't get the RGB working on the GPU and had to RMA. Not even using Trixx or MB software

Did the RGB get stuck once you went from "rainbow" to "external source"?

Did the RGB work with TriXX even though it stopped working via ARGB 5V 3-pin connector?

 

I contacted Sapphire and they said they will reject it for an RMA since TriXX is working so the "External Source" isn't the issue. This is ridiculous.

The TriXX lights up via PCIE and has nothing to do with the 3-pin 5V ARGB connector. What a joke of a company.

 

Did your new one work with the ARGB cable?

Edited by Titan777
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...