Jump to content
Corsair Community

Harpoon RGB Wired Mouse [Side Buttons + DPI non functional]


Recommended Posts

Hello, I am asking for some assistance in the issue I am having.

Device information:

CORSAIR GAMING HARPOON RGB MOUSE

RGP0030

Issue:

The other day I went to use my MOUSE4 (forward side button), I noticed that it wasn't being detected. I have never installed iCue as the mouse has worked flawlessly without it.

The given solutions below are what I have tried, however they have not worked.

  • Applied 3 macros, retaining the original key input on: FORWARD, BACKWARDS, DPI buttons.
  • Disconnected the mouse, held down the side buttons, reconnected the mouse while still holding the buttons and waited for the flash
  • Moved it into a different USB socket
  • Uninstalled the mouse via Device manager, restarted and allowed it to re-install the default driver
  • Removed any traces of Corsair folders in localappdata, appdata and program files(x86) and Program Files also deleted everything via REGEDIT related to corsair
  • Disabling ClickFast in the mouse settings

After doing all of these and having no luck, there is one way I can get the mouse to work correctly, however it is for a very brief time (5-10 seconds)

By holding down the side buttons and allowing the flash to occur, they will work for a short period of time (5-10 seconds as listed above).

 

Does anyone else have any other solutions for me to try or shall I just spend the £19.99 and purchase a new one?

 

Thank you.

Edited by iLukey96
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...