Jump to content
Corsair Community

CORSAIR iCUE v4.15.153 and v4.14.179 Incompatible with New World Easy Anti Cheat


StormEffect
 Share

Recommended Posts

Wanted to give everyone a warning that CORSAIR iCUE v4.15.153 and v4.14.179 (I think the lighting service, specifically) will trip New World's Easy Anti Cheat software.

I've rolled back v4.13.223, which appears compatible with New World Easy Anti Cheat.

Do not update beyond v4.13.223 if you play New World!

 

 

Link to comment
Share on other sites

that may be the first time iCUE can actually save your PC 😛

Link to comment
Share on other sites

E-Z Anti-Cheat is used by a number of games, not just New World.  This issue has popped up sporadically over the past two years and seems to affect particular users at times.  It's not as simple as "if you use CUE version X.xx" then it triggers.  Most users don't have an issue, while some get it continuously for a period of time. There is at least one secondary factor.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...