Jump to content
Corsair Community

Corsair H150i RGB Pro XT LL120 fans instead of ML120


Jedrexxx
 Share

Recommended Posts

Hi, I decided to change ML120's to LL120 RGB fans on my H150i radiator. The problem is that speed of LL120 can't be changed in iCUE. Adjustment of RPMs with ML120 connected to the pump works fine. What am I supposed to do?

Edited by Jedrexxx
Link to comment
Share on other sites

The H150i cannot distinguish one PWM fan from another so it should be able to control the fan speeds of the LL120 fans in exactly the same way as the ML120s.  It also should not matter if the RGB aspect is connected to the Lighting Node Pro Hub or not as that aspect is independent of the fan speed control.

Perhaps check that the USB cable was reconnected to the motherboard and pump as that is the part that controls the PWM fan speed signals (both the fan speeds and the pump).

Edited by Latharion
Link to comment
Share on other sites

Most of the time this comes up it's that the fan curve has not been properly applied.  There are lots of people using LL's on their AIOs.  If the issue is still ongoing, try and post a picture of the fan curves for us.  Also note, the LL may not be able to do "zero rpm mode".  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...