Jump to content
Corsair Community

Scimitar RGB Elite- Dead out of box


Recommended Posts

Exactly as the title says, the new Scimitar RGB Elite is (insofar as I can tell) dead out of the box. I ran updates prior to attempted installation, both iCue and general PC updates, and I've tried every USB slot available. The Corsair mouse when plugged in will not light up and does not register with any of the software. The cursor is unresponsive and none of the buttons work.

I put in a ticket, so hopefully the customer service team will help out, but I'm desperately hoping that maybe I'm just missing something. I've tried the reset instructions, just to see if that might help, but to no avail. This is damn disappointing, the mouse was a surprise gift from my spouse in addition to being somewhat in need as my G600 is slowly kicking the bucket.

Any advice would be welcome.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...