Jump to content
Corsair Community

How do I use my Virtuoso SE with the 3.5mm cable on PC?


RafaelP
 Share

Recommended Posts

I have a Corsair Virtuoso SE and sometimes I have issues with the wireless dongle and my wifi router. So, I'm forced to use a wired connection. However, I prefer to use the 3.5mm cable instead the USB due to it's plug position.

Whenever I connect the P3 cable, my mic stops working. I also bought a dual P3 to P2 splitter to use both mic and audio plugs, didn't work. What I'm I doing wrong?

If I keep using the USB all the time, will it ruin the battery?

 

MOBO: ROG Maximus Hero XI (latest BIOS)

Link to comment
Share on other sites

  • Corsair Employees
On 9/27/2021 at 3:11 PM, RafaelP said:

I have a Corsair Virtuoso SE and sometimes I have issues with the wireless dongle and my wifi router. So, I'm forced to use a wired connection. However, I prefer to use the 3.5mm cable instead the USB due to it's plug position.

Whenever I connect the P3 cable, my mic stops working. I also bought a dual P3 to P2 splitter to use both mic and audio plugs, didn't work. What I'm I doing wrong?

If I keep using the USB all the time, will it ruin the battery?

 

MOBO: ROG Maximus Hero XI (latest BIOS)

Hey RafaelP, are you using the 3.5mm cable that came with the headset? Also how close is your WIFI router to your setup for it to cause this kind of interference? 

Link to comment
Share on other sites

Hi Angie.

Yes, I am. But even with the Y splitter the mic doesn't work. I tried on my iPhone with the very same adapter and it worked very well.

I have a Deco X20 Mesh system and the main router is very close to my PC.

Link to comment
Share on other sites

  • Corsair Employees
19 hours ago, RafaelP said:

Hi Angie.

Yes, I am. But even with the Y splitter the mic doesn't work. I tried on my iPhone with the very same adapter and it worked very well.

I have a Deco X20 Mesh system and the main router is very close to my PC.

Did you check if your PC has a headphone-microphone combo jack in the back or anywhere? Not all splitter wires are made the same and unfortunately, it is difficult to recommend anything outside/third-party. If you're still experiencing issues, please reach out to our support. Please keep me updated as well 🙂 

Link to comment
Share on other sites

Yes, my mobo is pretty solid regarding audio. I just figured what happened. It was my audio driver, reinstalled and worked pretty good.

Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...