Jump to content
Corsair Community

Commander Pro not working with NZXT 2.0 Hub


Recommended Posts

I just built a brand new, RGB decked out PC. It's really awesome but managing all the fans and RGB has been a pain. I have the Lian Li 011 Dynamic with 9 QL fans. Three are used with my AIO (Kraken Z73) and work great but the other six I have routed through a Commander Pro. I also used the Node Cores included with the QLs to link up the RGB. Initially I had the Cores plugged in via the Commander Pro but found that the USB passthrough doesn't work well at the moment. So I found the NZXT USB Hub. I decided to get it in order to save from more heartache. I got it today and installed it. I plugged both Cores and the Commander Pro into it. Then I turned on my PC and the fans saw no movement. I opened iQue and only the Cores showed up (before the Commander Pro showed up). I have double checked all connections and can find no issue. The only other thing I did was install an adapter to connect my Lian Li Strimer Cables to the Commander Pro but I doubt that could be the issue. I haven't tried connecting the Commander Pro back into the MB but I may try that next. This is incredibly disappointing as I wanted to avoid having to write this but if anyone could let me know if they've had a similar issue, I'd love that. Thanks.

Setup:
CPU: 5900X
GPU: 3080 FTW3 Ultra
Motherboard: Crosshair VIII Dark Hero
RAM: 2x16 (32GB) G.Skill Triden Neo
AIO: NZXT Kraken Z73
PSU: Superflower Leadex III 850w
Fans: 9x Corsair QL
RGB Hub: 2x Corsair Node Cores
Fan Hub: Corsair Commander Pro
Misc:
Lian Li 24 Pin Strimer Plus
Lian Li 3x8 Pin Strimer Plus
Lian Li Lighting Hub
EZDIY-FAB Adapter Cable for Corsair Lighting Node Pro and for Corsair iCUE Commander PRO

 

Case Layout
------------------------
| AIO (Out) In |
| In |
| In In In In |
------------------------

In Wires ↓
In Wires ↓
In Wires → First Node Core RGB Headers
In Wires → Commander Pro Fan Headers
In Wires ↑
In Wires ↑

Out RGB ↓
Out RGB → Second Node Core
Out RGB ↑

Out Fan ↓
Out Fan → AIO Fan Headers
Out Fan ↑

Lian Li Lighting Hub WS2812B LED Control Signal → EZDIY-FAB Cable
EZDIY-FAB Cable → Commander Pro LED Headers

First Node Core ↓
Second Node Core → NZXT Internal USB Hub
Commander Pro ↑

NZXT Internal USB Hub → Mobo USB 2 Header

Link to comment
Share on other sites

I just tried plugging it into my MoBo and it didn't work either. I'm pretty sure the commander pro is dead. This is really disappointing. Off to submit an RMA.

Link to comment
Share on other sites

The NZXT hub was connected to the PSU too? Just asking to make sure 🙂

Link to comment
Share on other sites

If the fans on the Commander are not spinning, check the SATA connection for it. Software or not, usb connection or not, the fans should be forced into motion at power up. 

Edited by c-attack
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...