Jump to content
Corsair Community

LED on XG7/XC7 acting weird


Gasalon
 Share

Recommended Posts

After 6 months of having no issues suddenly the LEDs on my XC7 and XG7 are acting weird. It is a daisy chain XD5, XG7, XC7 plugged into a CoPro. 3 LEDs on the XG7 and all of the XC7 ones are flashing in random colors no matter what profile I set. I have narrowed it down to a single LED on the XG7. If I disable that one everything works again. So obviously that LED is sending a messed up signal down the line making all the other LEDs flash. However sometimes it also works normally with that LED enabled. Any idea what the issue could be? The LED is not dead otherwise it would not work at all. All components and iCue are updated to the latest version. What kind of issue can make it work some times  and some times not?

Link to comment
Share on other sites

heat?

often heat will make dodgy LEDs misbehave. does it happen more often when you're gaming and the XG7 is hot? could be a clue.

These issues can be intermittent. 

Link to comment
Share on other sites

Interesting idea… but it is actually the other way round. When booting from a cold state they always flash. After an hour of gaming when I try to turn that LED on again it works sometimes. But that wouldn‘t make sense would it?

Link to comment
Share on other sites

well i replaced a LED strip 2 weeks ago that behaved like that. the first led was flashing at boot and gradually went back to normal. but this one didn't disturb the rest of the chain. Depends what is failing. for me it was a LED die probably. on yours it may be the control chip for that LED that messes up data to the rest of the chain. there's lots of failure points, so you can experience pretty varied issues depending if it's a bond wire failing, the control chip, a solder joint, the flex substrate snapping off etc.. 

it's a mess 🙂 if something doesnt behave normally 100% of the time > replace

Maybe Corsair can ship to you a replacement strip. that would save you swapping the entire block

Link to comment
Share on other sites

I wasn’t aware that you can swap out the led strips on the XG7. Is there a manual somewhere? I checked and couldn’t find anything

Edited by Gasalon
Link to comment
Share on other sites

Corsair? a manual? heheee

I don't know how the XG7 RGB is fitted, but if it's like other blocks, that's just a strip embedded in the aesthetic front plate

Link to comment
Share on other sites

Yeah I thought so 😃. I guess that would still mean draining the loop, getting the GPU out and removing the block,  before anything can be  disassembled. Not sure if it is worth the risk for one LED that basically makes no optical difference. The acrylic block scatters the light very well on the XG7 and there is no dark spot. Thanks for your input, if more LEDs fail or if deactivating the faulty LED no longer works I guess I have no other choice than tearing it down.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...