Jump to content
Corsair Community

Scimitar RGB Elite iCue issues


BigZombieMonkey
 Share

Recommended Posts

Hi all, I am at my wits end at the moment with iCue and my Scimitar.
I have been looking for an answer all over the place but still had no luck.

Issue:
I have iCUE v. 4.14.179 installed on my PC and along with many other corsair RGB parts I am having no issue at all until it comes to the Scimitar. The issue in hand is that when I go to the Scimitar I can set all of my Key assignments, Hardware Key Assignments, Lighting effects, Hardware Lighting, DPI, Surface Calibration, Device Settings, they all work perfectly until I reset my PC and notice that the Scimitar is not using the Hardware Lighting I have set up, it is also not using the DPI settings I have set. 
This is not a major issue, it generally just means that I need to wait until my PC has booted up and iCue has loaded before my mouse acts the way I want it to, however, with the rest of my lighting being customised it is irritating that the mouse doesn't want to play ball.
I have tried doing to Device settings and clearing the onboard memory and then adding the current profile that is correct but it still seems to refuse to change from the rainbow lighting and DPI settings that I have not set when restarting or booting up the PC, when iCue is not active. I have tried soft resetting the mouse via unplugging, holding left and right click as you plug it in to get the slow rainbow scroll and then plugging it back in but again, when I make the changes I want it still refuses to play ball.

One very odd thing I have noticed is that when I restart the PC and go into iCue if I select hardware lighting the mouse will do the settings I have set, however the vengence RAM I have starts to do it's hardware setting colours, I have not used any lighting link in my lighting but for some reason the Scimitar section seems to trigger the RAM but no other parts on my PC such as the Lighting Node Pro, any of my fans or the H100I capellix pump light.

I have tried uninstalling all corsair products and reinstalling them but this has also not solved the issue. Could anyone help me before I give up on this mouse?

Link to comment
Share on other sites

  • 1 month later...

Hello, I just purchased the Scimitar Elite and I am having a very similar issue. When I create custom lighting using iCue it will work for a few minutes and then it will change to an all pink lighting scheme. I've uninstalled and reinstalled iCue, reset the mouse, deleted all profiles, and I have no conflicting lighting programs. No matter what I do it seems that nothing will work to fix the issue. Thanks! @Corsair Haurjie

Link to comment
Share on other sites

Ok so I figured out my issue and what was causing it. I don't know if this will help anyone else, but I honestly feel kinda dumb.... So I use Opera internet browser and apparently the color settings I have on my browser caused the lighting on my mouse to change. So every time I opened the browser my mouse would change to the color setting for Opera. Thanks guys and I hope this can help others as well.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...