Jump to content
Corsair Community

iCue on Big Sur not working?


brynn3
 Share

Recommended Posts

I tried to download iCue on Big Sur yesterday, didn't work for some reason. Today, i started up my Mac and idk how, but i had iCue downloaded. I was excited and i immediately opened it. My problem is, it says there are no devices connected. Do you have to connect them, somehow, to the software (if you get what i mean), or do they have to be connected to your mac? Cause i connected them to my Mac via a dock, but tthey still didn't show up in the iCue software. 

Link to comment
Share on other sites

  • Corsair Employees

What version of iCUE did you install and what devices do you have that are not showing up?

Link to comment
Share on other sites

I tried installing the iCue version made especially for macOS, that one said i had a too new iMac, and when i tried the other two versions, of the mouse and keyboard i have, and they both said i needed a software to open iCue. So they all didn't work. So i still can't figure out which one magically was downloaded this morning. Sorry if my replys are a bit vague. 

Link to comment
Share on other sites

  • Corsair Employees

If you open up the iCUE settings you should be able to see the version you installed.

Link to comment
Share on other sites

  • Corsair Employees

The K55 RGB Pro keyboard requires iCUE 4 which is currently in beta and not a public release. Please check your email associated with your account and you will receive a download link to the iCUE 4 beta download.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...