Jump to content
Corsair Community

K100 lighting bricked out of box


Recommended Posts

I drove 1 hour, each way to pick up a new K100 after my K70 died. I unboxed it, plugged it in and ICue asks to update the firmware. Wanting to be sure that did everything correct I did so and..... Lighting dead. Tried soft reset at least a dozen times. Tried a hard reset (Pinhole under keyboard) several times to no avail. Still bricked.

 

So either I drive 2 mores hours and exchange it, wait a week for Corsair's sad excuse for Support to respond to my ticket or ask you good folks here. I had more faith in you guys since Corsair seems only interested in selling stuff rather than actually supporting it.

 

Thanks in advance for any help provided. Cheers.

Link to comment
Share on other sites

So an update for anyone facing the same issue. 

 

Uninstalling and reinstalling ICue 4 did nothing. As a last resort before driving back to the store, I uninstalled ICue 4 and installed the latest version of iCue 3. Bang. Lit keyboard. I uninstalled ICue 3 and reinstalled ICue 4.... again.... and that did the trick. 

 

I guess paying top dollar for Corsair gear also signs you up to be an unpaid Beta tester for buggy/unfinished software... 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...