Jump to content
Corsair Community

Corsair Virtuoso OVERHEATING


Recommended Posts

Hi... so i got this issue that my USB-C cable overheat when i try to charge my headset. its not just "hot" i just cant touch the connector because it burns and i got a nice burn smell aswell. Also it doesnt charge my headset at all and for some reason i cant even use the other cable (jack 3.5) because it doesnt work on my pc. (its weird since i use it in my mac and it works so it might be just my problem to fix)

I have an intermitent red light too and cant find the way to fix it.

Dongle version: 0.16.80
Headset: 0.17.149

ive had this headset for almost 1 year. i had some noise issues but never burnt myself before with a cable. i dont want it to melt the usb or something...

i got this image that says "usb port capacity exceeded" when i try and plug the cable in the back usb of my computer, the front one doesnt get that message but burns too.

 

usb.png

Link to comment
Share on other sites

Posted (edited)
3 hours ago, Corsair Elito said:

Hi,

 

Can you indicate how exactly you have it connected? Do you have a hub or adapter? Is it plugged into the case or the MOBO?

Is your bios up to date?

i connected the original USB C into my frontal usb panel and back panel. i do not have a hub or adapter. front panel is te case and back panel to the MOBO, both give me the same overheating issue.

tried to charge it in my mac and the usb port got disabled automatically because of the same problem, it needs more power so the mac shut the ports down so nothing happens.

thought it was the cable that got bad BUT i tried witn 2 more cables and same problem. one of my friends that works with electronics tells me that my battery is not recieving the power from the usb c into the battery and the power gets the cable overheated because it doesnt have anywhere else to go. last try and in 1 sec had to unplug it since i was smelling something burn.

 

BIOS is up to date. got the pc in feb so i got the latest drivers and didnt have any issue before.

 

ps: my 3.5 jack connector works fine now, i didnt have the HD audio driver so that's why it didnt work so thats working. but i dont like to have a cord when i bought a wireless headset. let me know if anything i say makes sence to you since english is not my first language. if you need more info or pictures let me know.

 

thanks

IMG-3129.jpg

Edited by Tazztania
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...