Jump to content
Corsair Community

Corsair virtuoso not responding or charging


Recommended Posts

Hello, 

This started after my headset battery was completely empty. It just turned off and doesn't want to turn on again when being plugged in. There are no lights either. I tried plugging it in my phone brick for about an hour, still not working. Tried charging with my ps5 usb and usb c. Anyone got an idea since this is really annoying for being a 200$ headset.

Link to comment
Share on other sites

  • Corsair Employees

Hi iDev,

Sometimes the Virtuoso and Virtuoso SE headsets may not charge when connected to a system that is in a sleep state or turned off but still delivering 5V power through USB. This can also occur if you’re attempting to charge the Virtuoso headset through a wall charger.

We've fixed this issue with a firmware update. Make sure your Virtuoso firmware versions are:

  • Virtuoso headset: v 0.17.149 or later
  • Virtuoso headset wireless dongle: v 0.15.76 or later

If your headset is unable to update due to being unresponsive, try the following steps:

  • Make sure your headset is in USB mode and your computer is turned on.
  • Plug the headset into your computer with a USB Type C-A cable.
  • Unplug the headset from your computer.
  • Unplug the headset dongle from your computer.
  • Plug the dongle back into your computer.
  • Make sure your headset is in USB mode, then plug your headset back into your computer.
  • Leave your headset plugged in for 15 minutes so the battery can reach minimum charge.
  • See if your headset works as normal.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...