Jump to content
Corsair Community

K70 and HS60 volume control acting weird


Recommended Posts

I first got my k70 keyboard and the volume know was working fine. Then I got my hs60 headset and once connected the volume knob of both the keyboard and headset didn't work smoothly anymore . When making rapid adjustments to volume it takes about 5 seconds or more to catch up. I feel like this has something to do with the 2 devices volume control conflicting, though I am not entirely sure.

Link to comment
Share on other sites

  • Corsair Employees

Hi Misha,

We recommend performing a clean install of iCUE. Please follow the steps below:

 

  1. Open your computer's Control Panel.
  2. Open the Programs and Features options.
  3. Select Corsair Utility Engine in the list, and then select Uninstall.
  4. Press Window Key + R to open the Run command.
  5. Type %appdata% and press Enter.
  6. Delete any Corsair folders in the window that pops up.
  7. Return to the Run window and type %localappdata%.
  8. Delete any Corsair folders in the window that pops up.
  9. Open File Explorer and navigate to C:\Program Files (x86)\ for iCUE 3, or C:\Program Files\ for iCUE 4.
  10. Delete any Corsair folders in that folder.
  11. Type Regedit in the Run window and then click OK.
  12. Go to HKEY_CURRENT_USER\Software\ and delete the Corsair folder.
  13. Go to HKEY_LOCAL_MACHINE\SOFTWARE\ and delete the Corsair folder.
  14. Restart your computer.
  15. Download a new installer file for iCUE from Corsair.com and reinstall.

 

If you need assistance with these steps, please reach out to our support team by creating a ticket.

 

Thank you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...