Jump to content
Corsair Community

Problems with iCue (again)


xPrecision
 Share

Recommended Posts

Hello,

First of all let me apologize for my English, as it is not my native language.

Today I made a decision that I am already regretting: I tried to switch from LINK 4 to iCue in order to light up my fan set.

I have 3 LL120 fans connected to ports 1-3 on a commander pro and on an RGB Hub in turn connected to LED Port 1 in the commander pro. I also have another 3 ML120 fans connected to ports 4-6 on the commander pro and a series of 4 RGB LED strips connected to LED Port 2 in the commander pro. I hope this is all clear.

I have once tried to use iCue to light up this setup but failed miserably and so had reverted to LINK 4 which did the job: everything light up as I wanted.

Today, unfortunately, I made the decision of giving iCue another try: "What could possibly go wrong?  I can maybe get it to work now and if all goes wrong I can revert to LINK".

Further on, I'll refer to the RGB hub ports as just ports.

Well, sadly the story took a completely different turn. After replacing link with iCue only fan in port 1 lit up (lets call this fan A). At this point fan B is in port 2 and fan C in port 3. I started digging on this forum and saw the suggestion of switching the ports to which the fans were connected. It was said that if one LED in a fan stopped working, all of the following fans would too (let me say that this is by far one of the most egregious flaws, why put them all in series and let 1 fan ruin everything?).

I then swapped fan C with fan A. Now, both C and B lit up: C lit up completely, being in port 1, while B seemed to have the same problem that A had before.

I tried multiple configurations that resulted in some lighting up and none lighting up and had to give up. I returned to the LINK 4 software (which unfortunately isn't even supplied by Corsair anymore) and to my surprise, now everything is messed up when it clearly worked hours ago. How could this be? Did iCue mess up the LL fans?

I probably now need to replace fans A & B since they seem to both have problems, even though they were clearly working well before I gave a chance to iCue. A poor mistake.

Let me add that commander pro has the latest firmware, the bios is updated and the iCue version was the most recent.

I'm writing this in the hopes that someone can shed some light on possible causes and fixes for the problems that I'm having.

I have added an image that hopefully illustrates the situation I've just described.

Best regards

 

icue problems.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...