Jump to content
Corsair Community

Corsair Icue installer causes Shutdown


TheProScout
 Share

Recommended Posts

Hello everyone,
First of all my apologies for the wall of text,
and i hope its posted in the right section of the forum.. 
 

Im having alot of trouble with Installing Icue 3/4. 
Everytime when i install it, either around 64% / 75% or 100% of the installation progress my system loses power and instantly shutsdown. 

So far i tried these driver installers:

iCUESetup_4.14.179_release
iCUESetup_3.38.61_release
iCUESetup_3.20.80_release

Same reproduceable result, nearing installation completion - computer loses power, 

I have no clue which part of Icue is causing this.

These are my System Specs:

MB: Asus Zenith 2 Extreme
CPU: AMD Threadripper 3990X
Mem: G.Skill Ripjaws V 128 GB
GPU: Inno3d RTX 2080 TI
PSU: AX1200i (from 2012 nearly 9 years old) 
Fans: 10 x QL120
Commander Pro

2x  Lightning Core 
Mouse: Scimitar Pro
Keyboard: K95 RGB

So far this is the method of how i tried to solve this myself:

1*Reinstall windows on reformatted SSD's

2*make recovery point, 

3* Install any of the above mentioned drivers, installation reaches either (Icue 3) 64%/75% (Icue 4) 100% barely 2 seconds later the computer loses power to Kernal and instantly shuts down.

4*use Recovery point to reach stage before installing corsair drivers.

5* Restart windows in Safe mode and following the instructions from https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-  (side note, im never able to uninstall icue through the Control panel/uninstall because the installer never properly installs,) however all other methods from the link does work. 

After this is i tried different installation orders of updates/drivers for other hardware after wich i tried icue to see if that would make a difference, but it would always end up the same way with power loss upon icue reaching 100% installatiion. 

so progressing from step 5 i have a clean slate again. next i tried:

6*Update windows to "version 21H1 OS build 19043.1165" / Step 2* / Step 3* / Step 4* / Step 5* . 

7* Update GPU driver to latest: 471.68 / Step 2* / Step 3* / Step 4* / Step 5* . 

8* Update Motherboard drivers to latest / Step 2* / Step 3* / Step 4* / Step 5* . 

9* 

I can't think of any more methods to solve my issue, it always ends in the same way. I really hoped i would have been able to solve this manually by reinstalling windows, but i have ran out of ideas

I can only think of 1 thing that may be the cause, Icue installer causes a spike in voltage and the PSU wants to autoprotect the system and shutsdown. 

I should point out that the PSU itself still performs really well in any other application, be it an extensive benchmark or an heavy game. 

it Specifically only loses power when installing Icue. 

I hope someone can assist me with this, 
Greetings TheProScout

 

 

Link to comment
Share on other sites

Have you had this configuration running before installing iCUE? Is there anything else new in there?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...